summaryrefslogtreecommitdiffstats
path: root/php-doctrine-common.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-common.spec')
-rw-r--r--php-doctrine-common.spec41
1 files changed, 33 insertions, 8 deletions
diff --git a/php-doctrine-common.spec b/php-doctrine-common.spec
index a8032f8..347e48d 100644
--- a/php-doctrine-common.spec
+++ b/php-doctrine-common.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-common
#
-# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,13 +12,13 @@
%global github_owner doctrine
%global github_name common
-%global github_version 2.11.0
-%global github_commit b8ca1dcf6b0dc8a2af7a09baac8d0c48345df4ff
+%global github_version 2.13.3
+%global github_commit f3812c026e557892c34ef37f6ab808a6b567da7f
%global composer_vendor doctrine
%global composer_project common
-# "php": "~7.1"
+# "php": "^7.1 || ^8.0"
%global php_min_ver 7.1
# "doctrine/annotations": "^1.0"
# NOTE: Min version not 1.0 because autoloader required
@@ -46,8 +46,8 @@
# "doctrine/reflection": "^1.0"
%global doctrine_refl_min_ver 1.0
%global doctrine_refl_max_ver 2
-# "doctrine/persistence": "^1.1"
-%global doctrine_pers_min_ver 1.1
+# "doctrine/persistence": "^1.3.3"
+%global doctrine_pers_min_ver 1.3.3
%global doctrine_pers_max_ver 2
# Build using "--without tests" to disable tests
@@ -58,7 +58,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Epoch: 1
Version: %{github_version}
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Common library for Doctrine projects
License: MIT
@@ -69,6 +69,9 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# Minimal fix for PHP 8
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
# Library version value check
BuildRequires: php-cli
@@ -172,6 +175,9 @@ Autoloader: %{phpdir}/Doctrine/Common/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1 -b .php8
+
+sed -e 's/2.12.0-DEV/%{version}/' -i lib/Doctrine/Common/Version.php
%build
@@ -221,7 +227,7 @@ sed "s#require.*autoload.*#require_once '%{buildroot}%{phpdir}/Doctrine/Common/a
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73 php74; do
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit7 --verbose || RETURN_CODE=1
fi
@@ -245,6 +251,25 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 2.13.3-4
+- add minimal patch to fix test suite for PHP 8
+
+* Mon Jun 8 2020 Remi Collet <remi@remirepo.net> - 2.13.3-1
+- update to 2.13.3
+
+* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 2.13.2-1
+- update to 2.13.2
+
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 2.13.1-1
+- update to 2.13.1
+
+* Fri May 15 2020 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on doctrine/persistence 1.3.3
+
+* Mon Jan 13 2020 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+
* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0
- switch to phpunit7