summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-30 12:29:46 +0200
committerRemi Collet <remi@php.net>2022-09-30 12:29:46 +0200
commit622a1f375de9b98371a31158509384ee3bd8d7b0 (patch)
tree6fdac293b1c6ce4bd84be3df7c8a6ae3553e9693
parent6d2e32378f32646c8ec2e0a003b9d686fc490c3e (diff)
update to 2.0.1HEADmaster
-rw-r--r--composer.json4
-rw-r--r--php-doctrine-collections2.spec20
2 files changed, 13 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 209e0e6..99ec24b 100644
--- a/composer.json
+++ b/composer.json
@@ -46,12 +46,12 @@
},
"autoload": {
"psr-4": {
- "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections"
+ "Doctrine\\Common\\Collections\\": "src"
}
},
"autoload-dev": {
"psr-4": {
- "Doctrine\\Tests\\": "tests/Doctrine/Tests"
+ "Doctrine\\Tests\\": "tests"
}
},
"config": {
diff --git a/php-doctrine-collections2.spec b/php-doctrine-collections2.spec
index 5bd60d4..0600af8 100644
--- a/php-doctrine-collections2.spec
+++ b/php-doctrine-collections2.spec
@@ -10,8 +10,8 @@
%global github_owner doctrine
%global github_name collections
-%global github_version 2.0.0
-%global github_commit fbc051ebfdb0d11560c86491867cb9268a4d1a8e
+%global github_version 2.0.1
+%global github_commit d766a450ba818dacc4b1f50a56cfaad4683cefef
%global composer_vendor doctrine
%global composer_project collections
@@ -96,13 +96,12 @@ Autoloader: %{phpdir}/Doctrine/Common/Collections/autoload.php
%build
-mv lib/Doctrine/Common/Collections lib/Doctrine/Common/Collections%{major}
: Create autoloader
phpab --template fedora \
- --output lib/Doctrine/Common/Collections%{major}/autoload.php \
- lib/Doctrine/Common/Collections%{major}
+ --output src/autoload.php \
+ src
-cat <<'AUTOLOAD' | tee -a lib/Doctrine/Common/Collections%{major}/autoload.php
+cat <<'AUTOLOAD' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{phpdir}/Doctrine/Deprecations/autoload.php',
]);
@@ -110,8 +109,8 @@ AUTOLOAD
%install
-mkdir -p %{buildroot}%{phpdir}
-cp -rp lib/* %{buildroot}%{phpdir}/
+mkdir -p %{buildroot}%{phpdir}/Doctrine/Common/
+cp -rp src %{buildroot}%{phpdir}/Doctrine/Common/Collections%{major}
%check
@@ -120,7 +119,7 @@ cp -rp lib/* %{buildroot}%{phpdir}/
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
require_once '%{buildroot}%{phpdir}/Doctrine/Common/Collections%{major}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Tests\\', __DIR__.'/tests/Doctrine/Tests');
+\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Tests\\', __DIR__.'/tests');
BOOTSTRAP
: Upstream tests
@@ -150,6 +149,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Fri Sep 30 2022 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+
* Fri Sep 30 2022 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- rename to php-doctrine-collections2