summaryrefslogtreecommitdiffstats
path: root/php-doctrine-collections.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-collections.spec')
-rw-r--r--php-doctrine-collections.spec33
1 files changed, 16 insertions, 17 deletions
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
index 8164b44..f698ee0 100644
--- a/php-doctrine-collections.spec
+++ b/php-doctrine-collections.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-collections
#
-# Copyright (c) 2013-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,14 +12,14 @@
%global github_owner doctrine
%global github_name collections
-%global github_version 1.4.0
-%global github_commit 1a4fb7e902202c33cce8c55989b945612943c2ba
+%global github_version 1.6.0
+%global github_commit acc35813077be497dc7f658af76729fa456444e3
%global composer_vendor doctrine
%global composer_project collections
-# "php": "^5.6 || ^7.0"
-%global php_min_ver 5.6
+# "php": "^7.1.3"
+%global php_min_ver 7.1.3
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Collections abstraction library
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
@@ -40,14 +39,13 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: phpunit7
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 1.4.0)
+## phpcompatinfo (computed from version 1.6.0)
BuildRequires: php-pcre
BuildRequires: php-spl
# Autoloader
@@ -56,7 +54,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.4.0)
+# phpcompatinfo (computed from version 1.6.0)
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -93,7 +91,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{phpdir}
cp -rp lib/* %{buildroot}%{phpdir}/
@@ -108,13 +105,10 @@ require_once '%{buildroot}%{phpdir}/Doctrine/Common/Collections/autoload.php';
BOOTSTRAP
: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
-
-: Upstream tests with SCLs if available
SCL_RETURN_CODE=0
-for SCL in php70 php71; do
+for SCL in php php71 php72 php73; do
if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
+ $SCL %{_bindir}/phpunit7 --verbose --bootstrap bootstrap.php \
|| SCL_RETURN_CODE=1
fi
done
@@ -129,7 +123,7 @@ rm -rf %{buildroot}
%files
-%defattr(-,root,root,-)
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -140,6 +134,11 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 25 2019 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- raise dependency on PHP 7.1.3
+- use PHPUnit 7 for test suite
+
* Sat Mar 04 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.4.0-1
- Updated to 1.4.0 (RHBZ #1415530)
- Switched autoloader to php-composer(fedora/autoloader)