summaryrefslogtreecommitdiffstats
path: root/php-doctrine-collections.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-collections.spec')
-rw-r--r--php-doctrine-collections.spec32
1 files changed, 21 insertions, 11 deletions
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
index ea93747..c3ddf18 100644
--- a/php-doctrine-collections.spec
+++ b/php-doctrine-collections.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-collections
#
-# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name collections
-%global github_version 1.6.6
-%global github_commit 5f0470363ff042d0057006ae7acabc5d7b5252d5
+%global github_version 1.6.7
+%global github_commit 55f8b799269a1a472457bd1a41b4f379d4cfba4a
%global composer_vendor doctrine
%global composer_project collections
@@ -39,11 +39,19 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# Upstream patch for PHPUnit >= 8
+Patch0: %{name}-phpunit.patch
+
BuildArch: noarch
# Tests
%if %{with tests}
## composer.json
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 32
+%global phpunit %{_bindir}/phpunit9
+%else
+%global phpunit %{_bindir}/phpunit8
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= %{php_min_ver}
## phpcompatinfo (computed from version 1.6.0)
BuildRequires: php-pcre
@@ -74,6 +82,7 @@ Autoloader: %{phpdir}/Doctrine/Common/Collections/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1
%build
@@ -106,9 +115,10 @@ BOOTSTRAP
: Upstream tests
SCL_RETURN_CODE=0
-for SCL in php php71 php72 php73 php74 php80; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit7 --verbose --bootstrap bootstrap.php \
+for CMD in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74 "php80 %{_bindir}/phpunit9"; do
+ if which $CMD; then
+ set $CMD
+ $1 ${2:-%{_bindir}/phpunit8} --verbose --bootstrap bootstrap.php \
|| SCL_RETURN_CODE=1
fi
done
@@ -118,10 +128,6 @@ exit $SCL_RETURN_CODE
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
# remirepo:1
%{!?_licensedir:%global license %%doc}
@@ -134,6 +140,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7
+- add upstream patch for recent PHPUnit
+
* Mon Jul 20 2020 Remi Collet <remi@remirepo.net> - 1.6.6-1
- update to 1.6.6