summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-doctrine-collections-phpunit.patch28
-rw-r--r--php-doctrine-collections.spec19
3 files changed, 11 insertions, 44 deletions
diff --git a/composer.json b/composer.json
index f0b6a4a..9a6494e 100644
--- a/composer.json
+++ b/composer.json
@@ -21,10 +21,10 @@
"php": "^7.1.3 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^7.0",
- "doctrine/coding-standard": "^6.0",
- "phpstan/phpstan-shim": "^0.9.2",
- "vimeo/psalm": "^3.8.1"
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.1.5",
+ "doctrine/coding-standard": "^9.0",
+ "phpstan/phpstan": "^0.12",
+ "vimeo/psalm": "^4.2.1"
},
"autoload": {
"psr-4": { "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections" }
diff --git a/php-doctrine-collections-phpunit.patch b/php-doctrine-collections-phpunit.patch
deleted file mode 100644
index d41d18d..0000000
--- a/php-doctrine-collections-phpunit.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From upstream:
-
-
-From bc598aa22269c32e2ad4bcdad2158b280c92132d Mon Sep 17 00:00:00 2001
-From: "Jonathan H. Wage" <jonwage@gmail.com>
-Date: Tue, 30 Apr 2019 17:39:05 -0500
-Subject: [PATCH] Upgrade to PHPUnit 8.
-
----
- .gitignore | 7 +-
- composer.json | 2 +-
- composer.lock | 79 ++++++++++---------
- .../Common/Collections/BaseCollectionTest.php | 2 +-
- 4 files changed, 46 insertions(+), 44 deletions(-)
-
-diff --git a/tests/Doctrine/Tests/Common/Collections/BaseCollectionTest.php b/tests/Doctrine/Tests/Common/Collections/BaseCollectionTest.php
-index 6f21cf56..d563ade5 100644
---- a/tests/Doctrine/Tests/Common/Collections/BaseCollectionTest.php
-+++ b/tests/Doctrine/Tests/Common/Collections/BaseCollectionTest.php
-@@ -205,7 +205,7 @@ public function testSlice() : void
- $this->collection[] = 'three';
-
- $slice = $this->collection->slice(0, 1);
-- self::assertInternalType('array', $slice);
-+ self::assertIsArray($slice);
- self::assertEquals(['one'], $slice);
-
- $slice = $this->collection->slice(1);
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
index c3ddf18..8ceed23 100644
--- a/php-doctrine-collections.spec
+++ b/php-doctrine-collections.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name collections
-%global github_version 1.6.7
-%global github_commit 55f8b799269a1a472457bd1a41b4f379d4cfba4a
+%global github_version 1.6.8
+%global github_commit 1958a744696c6bb3bb0d28db2611dc11610e78af
%global composer_vendor doctrine
%global composer_project collections
@@ -39,18 +39,11 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-# Upstream patch for PHPUnit >= 8
-Patch0: %{name}-phpunit.patch
-
BuildArch: noarch
# Tests
%if %{with tests}
## composer.json
-%if 0%{?fedora} >= 32
%global phpunit %{_bindir}/phpunit9
-%else
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: %{phpunit}
BuildRequires: php(language) >= %{php_min_ver}
## phpcompatinfo (computed from version 1.6.0)
@@ -82,7 +75,6 @@ Autoloader: %{phpdir}/Doctrine/Common/Collections/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
%build
@@ -115,10 +107,10 @@ BOOTSTRAP
: Upstream tests
SCL_RETURN_CODE=0
-for CMD in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74 "php80 %{_bindir}/phpunit9"; do
+for CMD in "php %{phpunit}" php73 php74 php80 php81; do
if which $CMD; then
set $CMD
- $1 ${2:-%{_bindir}/phpunit8} --verbose --bootstrap bootstrap.php \
+ $1 ${2:-%{_bindir}/phpunit9} --verbose --bootstrap bootstrap.php \
|| SCL_RETURN_CODE=1
fi
done
@@ -140,6 +132,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Wed Aug 11 2021 Remi Collet <remi@remirepo.net> - 1.6.8-1
+- update to 1.6.8
+
* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.6.7-1
- update to 1.6.7
- add upstream patch for recent PHPUnit