summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-11 15:21:33 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-11 15:21:33 +0100
commita230113fdc55b2de7627833d5a5e9a222a5cffef (patch)
treed246330b727fceebf90cc5514793b501c2b89e3c
php-doctrine-collections: import from rawhide
-rw-r--r--php-doctrine-collections.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
new file mode 100644
index 0000000..e472901
--- /dev/null
+++ b/php-doctrine-collections.spec
@@ -0,0 +1,85 @@
+%global github_owner doctrine
+%global github_name collections
+%global github_version 1.1
+%global github_commit 819871759a4d41dab244d358507bd27d0e8b1e33
+# Additional commits after v1.1 tag
+%global github_release .20131221git%(c=%{github_commit}; echo ${c:0:7})
+
+# "php": ">=5.3.2"
+%global php_min_ver 5.3.2
+
+Name: php-%{github_owner}-%{github_name}
+Version: %{github_version}
+Release: 3%{?github_release}%{?dist}
+Summary: Collections abstraction library
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+# For tests
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+# For tests: phpcompatinfo (computed from v1.1 git commit 819871759a4d41dab244d358507bd27d0e8b1e33)
+BuildRequires: php-spl
+
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo (computed from v1.1 git commit 819871759a4d41dab244d358507bd27d0e8b1e33)
+Requires: php-spl
+
+# Extracted from Doctrine Common as of version 2.4
+Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
+
+%description
+%{summary}.
+
+
+%prep
+%setup -q -n %{github_name}-%{github_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -p %{buildroot}/%{_datadir}/php
+cp -rp lib/* %{buildroot}/%{_datadir}/php/
+
+
+%check
+# Create tests' autoload
+mkdir vendor
+cat > vendor/autoload.php <<'AUTOLOAD'
+<?php
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', str_replace('_', '/', $class)).'.php';
+ @include_once $src;
+});
+AUTOLOAD
+
+# Create PHPUnit config w/ colors turned off
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
+
+%{_bindir}/phpunit --include-path ./lib:./tests -d date.timezone="UTC"
+
+
+%files
+%doc LICENSE *.md composer.json
+%dir %{_datadir}/php/Doctrine
+%dir %{_datadir}/php/Doctrine/Common
+ %{_datadir}/php/Doctrine/Common/Collections
+
+
+%changelog
+* Mon Jan 06 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1-3.20131221git8198717
+- Minor syntax changes
+
+* Fri Jan 03 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1-2.20131221git8198717
+- Conditional %%{?dist}
+- Added conflict w/ PEAR-based DoctrineCommon pkg (version < 2.4)
+
+* Mon Dec 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1-1.20131221git8198717
+- Initial package