summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-26 08:16:11 +0200
committerRemi Collet <remi@remirepo.net>2020-05-26 08:16:11 +0200
commit7566fe47faa2234c2986e82f08db170a6850eefa (patch)
treec6061e8d4537833aeb3eaf3db2c155c1c24e8149
parent82eb764e980fae29b00b32d3b58854a3db1f7f74 (diff)
update to 1.6.5
-rw-r--r--composer.json9
-rw-r--r--php-doctrine-collections.spec11
2 files changed, 9 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 828a7d2..f0b6a4a 100644
--- a/composer.json
+++ b/composer.json
@@ -18,13 +18,13 @@
{"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
],
"require": {
- "php": "^7.1.3"
+ "php": "^7.1.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^7.0",
"doctrine/coding-standard": "^6.0",
"phpstan/phpstan-shim": "^0.9.2",
- "vimeo/psalm": "^3.2.2"
+ "vimeo/psalm": "^3.8.1"
},
"autoload": {
"psr-4": { "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections" }
@@ -33,10 +33,5 @@
"psr-4": {
"Doctrine\\Tests\\": "tests/Doctrine/Tests"
}
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.6.x-dev"
- }
}
}
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
index e6a18ca..9f7187e 100644
--- a/php-doctrine-collections.spec
+++ b/php-doctrine-collections.spec
@@ -12,13 +12,13 @@
%global github_owner doctrine
%global github_name collections
-%global github_version 1.6.4
-%global github_commit 6b1e4b2b66f6d6e49983cebfe23a21b7ccc5b0d7
+%global github_version 1.6.5
+%global github_commit fc0206348e17e530d09463fef07ba8968406cd6d
%global composer_vendor doctrine
%global composer_project collections
-# "php": "^7.1.3"
+# "php": "^7.1.3 || ^8.0"
%global php_min_ver 7.1.3
# Build using "--without tests" to disable tests
@@ -106,7 +106,7 @@ BOOTSTRAP
: Upstream tests
SCL_RETURN_CODE=0
-for SCL in php php71 php72 php73 php74; do
+for SCL in php php71 php72 php73 php74 php80; do
if which $SCL; then
$SCL %{_bindir}/phpunit7 --verbose --bootstrap bootstrap.php \
|| SCL_RETURN_CODE=1
@@ -134,6 +134,9 @@ rm -rf %{buildroot}
%changelog
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.6.5-1
+- update to 1.6.5
+
* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 1.6.4-1
- update to 1.6.4