summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-09 08:41:50 +0200
committerRemi Collet <remi@php.net>2022-09-09 08:41:50 +0200
commit25702d8c2e195062ca8daa077771b842bb997a9e (patch)
treee12a38afde5520c5815a4f096645ff03e5ff2a93
parente3d442869abc9f5ca89b4c887d3d9abaf908d4e6 (diff)
update to 1.6.9
-rw-r--r--composer.json47
-rw-r--r--php-doctrine-collections.spec7
2 files changed, 40 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 9a6494e..4409f10 100644
--- a/composer.json
+++ b/composer.json
@@ -1,37 +1,60 @@
{
"name": "doctrine/collections",
- "type": "library",
"description": "PHP Doctrine Collections library that adds additional functionality on top of PHP arrays.",
+ "license": "MIT",
+ "type": "library",
"keywords": [
"php",
"collections",
"array",
"iterators"
],
- "homepage": "https://www.doctrine-project.org/projects/collections.html",
- "license": "MIT",
"authors": [
- {"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
- {"name": "Roman Borschel", "email": "roman@code-factory.org"},
- {"name": "Benjamin Eberlei", "email": "kontakt@beberlei.de"},
- {"name": "Jonathan Wage", "email": "jonwage@gmail.com"},
- {"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
+ {
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@gmail.com"
+ },
+ {
+ "name": "Roman Borschel",
+ "email": "roman@code-factory.org"
+ },
+ {
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
+ },
+ {
+ "name": "Jonathan Wage",
+ "email": "jonwage@gmail.com"
+ },
+ {
+ "name": "Johannes Schmitt",
+ "email": "schmittjoh@gmail.com"
+ }
],
+ "homepage": "https://www.doctrine-project.org/projects/collections.html",
"require": {
"php": "^7.1.3 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^7.5 || ^8.5 || ^9.1.5",
"doctrine/coding-standard": "^9.0",
- "phpstan/phpstan": "^0.12",
- "vimeo/psalm": "^4.2.1"
+ "phpstan/phpstan": "^1.4.8",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.1.5",
+ "vimeo/psalm": "^4.22"
},
"autoload": {
- "psr-4": { "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections" }
+ "psr-4": {
+ "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections"
+ }
},
"autoload-dev": {
"psr-4": {
"Doctrine\\Tests\\": "tests/Doctrine/Tests"
}
+ },
+ "config": {
+ "allow-plugins": {
+ "composer/package-versions-deprecated": true,
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
}
}
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
index 8ceed23..2b16c32 100644
--- a/php-doctrine-collections.spec
+++ b/php-doctrine-collections.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name collections
-%global github_version 1.6.8
-%global github_commit 1958a744696c6bb3bb0d28db2611dc11610e78af
+%global github_version 1.6.9
+%global github_commit 1269d42c03f8a1cc9b56a1b727568423268a191b
%global composer_vendor doctrine
%global composer_project collections
@@ -132,6 +132,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Fri Sep 9 2022 Remi Collet <remi@remirepo.net> - 1.6.9-1
+- update to 1.6.9
+
* Wed Aug 11 2021 Remi Collet <remi@remirepo.net> - 1.6.8-1
- update to 1.6.8