summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-22 10:30:04 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-22 10:30:04 +0200
commit224353114c5d1d8a8ed4ed3a75b19faaa096b1e1 (patch)
tree8d5ed7b4a622d9675d72af9e613b60f1739ea4fb
parent62e3daaf75f48d846e809398294870ea9f422ee4 (diff)
php-doctrine-collections: rawhide changes
-rw-r--r--php-doctrine-collections.spec50
1 files changed, 40 insertions, 10 deletions
diff --git a/php-doctrine-collections.spec b/php-doctrine-collections.spec
index 8e2e6cc..52fb8df 100644
--- a/php-doctrine-collections.spec
+++ b/php-doctrine-collections.spec
@@ -1,14 +1,31 @@
-%global github_owner doctrine
-%global github_name collections
-%global github_version 1.2
-%global github_commit b99c5c46c87126201899afe88ec490a25eedd6a2
+#
+# RPM spec file for php-doctrine-collections
+#
+# Copyright (c) 2013-2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner doctrine
+%global github_name collections
+%global github_version 1.2
+%global github_commit b99c5c46c87126201899afe88ec490a25eedd6a2
+
+%global composer_vendor doctrine
+%global composer_project collections
# "php": ">=5.3.2"
-%global php_min_ver 5.3.2
+%global php_min_ver 5.3.2
-Name: php-%{github_owner}-%{github_name}
+# Build using "--without tests" to disable tests
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 3%{?github_release}%{?dist}
Summary: Collections abstraction library
Group: Development/Libraries
@@ -18,16 +35,21 @@ Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{githu
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+BuildRequires: php-phpunit-PHPUnit
# For tests: phpcompatinfo (computed from v1.2)
BuildRequires: php-spl
+%endif
Requires: php(language) >= %{php_min_ver}
# phpcompatinfo (computed from v1.2)
Requires: php-spl
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
# Extracted from Doctrine Common as of version 2.4
Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
@@ -36,7 +58,7 @@ Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
%prep
-%setup -q -n %{github_name}-%{github_commit}
+%setup -qn %{github_name}-%{github_commit}
%build
@@ -50,7 +72,8 @@ cp -rp lib/* %{buildroot}/%{_datadir}/php/
%check
-# Create tests' autoload
+%if %{with_tests}
+# Create autoloader
mkdir vendor
cat > vendor/autoload.php <<'AUTOLOAD'
<?php
@@ -64,6 +87,9 @@ AUTOLOAD
sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%{_bindir}/phpunit --include-path ./lib:./tests -d date.timezone="UTC"
+%else
+: Tests skipped
+%endif
%clean
@@ -79,6 +105,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2-3
+- Added php-composer(%%{composer_vendor}/%%{composer_project}) virtual provide
+- Added option to build without tests ("--without tests")
+
* Mon Feb 17 2014 Remi Collet <rpms@famillecollet.com> 1.2-1
- backport 1.2 for remi repo