summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 09:51:48 +0100
committerRemi Collet <remi@php.net>2022-12-20 09:51:48 +0100
commit6f30034c9086f8511a595a0e3445bc28aea94da1 (patch)
tree0fbbc25dd55d49cf4efb42d8e6c6275efc50040f
duplicate v1
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json72
l---------makesrc.sh1
-rwxr-xr-xphp-doctrine-annotations2-get-source.sh64
-rw-r--r--php-doctrine-annotations2.spec318
6 files changed, 468 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e322d82
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,72 @@
+{
+ "name": "doctrine/annotations",
+ "description": "Docblock Annotations Parser",
+ "license": "MIT",
+ "type": "library",
+ "keywords": [
+ "annotations",
+ "docblock",
+ "parser"
+ ],
+ "authors": [
+ {
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@gmail.com"
+ },
+ {
+ "name": "Roman Borschel",
+ "email": "roman@code-factory.org"
+ },
+ {
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
+ },
+ {
+ "name": "Jonathan Wage",
+ "email": "jonwage@gmail.com"
+ },
+ {
+ "name": "Johannes Schmitt",
+ "email": "schmittjoh@gmail.com"
+ }
+ ],
+ "homepage": "https://www.doctrine-project.org/projects/annotations.html",
+ "require": {
+ "php": "^7.1 || ^8.0",
+ "ext-tokenizer": "*",
+ "doctrine/lexer": "^1 || ^2",
+ "psr/cache": "^1 || ^2 || ^3"
+ },
+ "require-dev": {
+ "doctrine/cache": "^1.11 || ^2.0",
+ "doctrine/coding-standard": "^9 || ^10",
+ "phpstan/phpstan": "~1.4.10 || ^1.8.0",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+ "symfony/cache": "^4.4 || ^5.4 || ^6",
+ "vimeo/psalm": "^4.10"
+ },
+ "suggest": {
+ "php": "PHP 8.0 or higher comes with attributes, a native replacement for annotations"
+ },
+ "autoload": {
+ "psr-4": {
+ "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Doctrine\\Performance\\Common\\Annotations\\": "tests/Doctrine/Performance/Common/Annotations",
+ "Doctrine\\Tests\\Common\\Annotations\\": "tests/Doctrine/Tests/Common/Annotations"
+ },
+ "files": [
+ "tests/Doctrine/Tests/Common/Annotations/Fixtures/functions.php",
+ "tests/Doctrine/Tests/Common/Annotations/Fixtures/SingleClassLOC1000.php"
+ ]
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "sort-packages": true
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..e61802f
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-doctrine-annotations2-get-source.sh \ No newline at end of file
diff --git a/php-doctrine-annotations2-get-source.sh b/php-doctrine-annotations2-get-source.sh
new file mode 100755
index 0000000..f8f69e8
--- /dev/null
+++ b/php-doctrine-annotations2-get-source.sh
@@ -0,0 +1,64 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+SPEC=`ls *.spec`
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-doctrine-annotations2.spec b/php-doctrine-annotations2.spec
new file mode 100644
index 0000000..2e0f97d
--- /dev/null
+++ b/php-doctrine-annotations2.spec
@@ -0,0 +1,318 @@
+# remirepo spec file for php-doctrine-annotations, from:
+#
+# Fedora spec file for php-doctrine-annotations
+#
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+# Build using "--without tests" to disable tests
+%bcond_without tests
+
+%global github_owner doctrine
+%global github_name annotations
+%global github_version 1.14.2
+%global github_commit ad785217c1e9555a7d6c6c8c9f406395a5e2882b
+
+%global composer_vendor doctrine
+%global composer_project annotations
+
+# "php": "^7.1 || ^8.0"
+%global php_min_ver 7.1
+# "doctrine/cache": "^1.11 || ^2."
+%global cache_min_ver 1.11
+%global cache_max_ver 3
+# "doctrine/lexer": "^1 || ^2"
+# NOTE: Min version not 1.0 because autoloader required
+%global lexer_min_ver 1.0.1
+%global lexer_max_ver 3
+# "psr/cache": "^1 || ^2 || ^3"
+%global psr_cache_min_ver 1
+# only v1 is available for now
+%global psr_cache_max_ver 2
+# "symfony/cache": "^4.4 || ^5.2"
+%global symfony_min_ver 4.4
+%global symfony_max_ver 6
+
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: PHP docblock annotations parser library
+
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-doctrine-annotations-get-source.sh to create full source.
+Source0: %{name}-%{version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires:(php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
+BuildRequires:(php-composer(doctrine/lexer) >= %{lexer_min_ver} with php-composer(doctrine/lexer) < %{lexer_max_ver})
+BuildRequires:(php-composer(psr/cache) >= %{psr_cache_min_ver} with php-composer(psr/cache) < %{psr_cache_max_ver})
+BuildRequires:(php-composer(symfony/cache) >= %{symfony_min_ver} with php-composer(symfony/cache) < %{symfony_max_ver})
+# remirepo:8
+%else
+BuildRequires: php-doctrine-cache < %{cache_max_ver}
+BuildRequires: php-doctrine-cache >= %{cache_min_ver}
+BuildRequires: php-doctrine-lexer < %{lexer_max_ver}
+BuildRequires: php-doctrine-lexer >= %{lexer_min_ver}
+BuildRequires: php-psr-cache >= %{psr_cache_min_ver}
+BuildRequires: php-symfony4-cache >= %{symfony_min_ver}
+%endif
+# "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5"
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5
+
+## phpcompatinfo (computed from version 1.10.0)
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-json
+BuildRequires: php-mbstring
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+BuildRequires: php-tokenizer
+%endif
+# Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+Requires: php-tokenizer
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(doctrine/lexer) >= %{lexer_min_ver} with php-composer(doctrine/lexer) < %{lexer_max_ver})
+Requires: (php-composer(psr/cache) >= %{psr_cache_min_ver} with php-composer(psr/cache) < %{psr_cache_max_ver})
+# remirepo:6
+%else
+Requires: php-doctrine-lexer < %{lexer_max_ver}
+Requires: php-doctrine-lexer >= %{lexer_min_ver}
+Requires: php-psr-cache < %{psr_cache_max_ver}
+Requires: php-psr-cache >= %{psr_cache_min_ver}
+%endif
+# phpcompatinfo (computed from version 1.10.0)
+Requires: php-ctype
+Requires: php-date
+Requires: php-json
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+# Extracted from Doctrine Common as of version 2.4
+Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
+
+%description
+%{summary} (extracted from Doctrine Common).
+
+Autoloader: %{phpdir}/Doctrine/Common/Annotations/autoload.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee lib/Doctrine/Common/Annotations/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Common\\Annotations\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required([
+ [
+ '%{phpdir}/Doctrine/Common/Lexer2/autoload.php',
+ '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
+ ],
+ '%{phpdir}/Psr/Cache/autoload.php',
+]);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}
+cp -rp lib/* %{buildroot}%{phpdir}/
+
+
+%check
+%if %{with tests}
+: Create tests bootstrap
+mkdir vendor
+cat <<'BOOTSTRAP' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{phpdir}/Doctrine/Common/Annotations/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ [
+ '%{phpdir}/Doctrine/Common/Cache2/autoload.php',
+ '%{phpdir}/Doctrine/Common/Cache/autoload.php',
+ ], [
+ '%{phpdir}/Symfony5/Component/Cache/autoload.php',
+ '%{phpdir}/Symfony4/Component/Cache/autoload.php',
+ ],
+ dirname( __DIR__) . '/tests/Doctrine/Tests/TestInit.php',
+ dirname( __DIR__) . '/tests/Doctrine/Tests/Common/Annotations/Fixtures/functions.php',
+ dirname( __DIR__) . '/tests/Doctrine/Tests/Common/Annotations/Fixtures/SingleClassLOC1000.php',
+]);
+BOOTSTRAP
+
+: Upstream tests
+RETURN_CODE=0
+for CMD in "php %{phpunit}" php80 php81 php82; do
+ if which $CMD; then
+ set $CMD
+ $1 ${2:-%{_bindir}/phpunit9} --verbose \
+ -d pcre.recursion_limit=10000 \
+ --filter '^((?!(testAvoidCallingFilemtimeTooMuch)).)*$' \
+ || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{phpdir}/Doctrine/Common/Annotations
+
+
+%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 1.14.2-1
+- update to 1.14.2
+
+* Tue Dec 13 2022 Remi Collet <remi@remirepo.net> - 1.14.1-1
+- update to 1.14.1
+- allow doctrine/lexer v2
+
+* Mon Jul 4 2022 Remi Collet <remi@remirepo.net> - 1.13.3-1
+- update to 1.13.3
+
+* Fri Aug 6 2021 Remi Collet <remi@remirepo.net> - 1.13.2-1
+- update to 1.13.2
+
+* Mon May 17 2021 Remi Collet <remi@remirepo.net> - 1.13.1-2
+- allow doctrine/cache v2
+
+* Mon May 17 2021 Remi Collet <remi@remirepo.net> - 1.13.1-1
+- update to 1.13.1
+- add runtime dependency on psr/cache
+- add build dependency on symfony/cache
+
+* Wed Feb 24 2021 Remi Collet <remi@remirepo.net> - 1.12.1-1
+- update to 1.12.1
+
+* Tue Oct 27 2020 Remi Collet <remi@remirepo.net> - 1.11.1-1
+- update to 1.11.1
+
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+
+* Wed Aug 12 2020 Remi Collet <remi@remirepo.net> - 1.10.4-1
+- update to 1.10.4
+- switch to phpunit9
+
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.10.3-1
+- update to 1.10.3 (no change)
+
+* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 1.10.2-1
+- update to 1.10.2
+
+* Thu Apr 2 2020 Remi Collet <remi@remirepo.net> - 1.10.1-1
+- update to 1.10.1
+
+* Thu Apr 2 2020 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+
+* Wed Oct 2 2019 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+
+* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0
+- switch to phpunit7
+
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- update to 1.6.1
+
+* Wed Oct 17 2018 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- raise dependency on PHP 7.1
+- use phpunit6
+- use range dependencies
+
+* Fri May 12 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.7-4
+- Switch autoloader to php-composer(fedora/autoloader)
+- Add max versions to build dependencies
+- Test with SCLs if available
+
+* Sat Sep 05 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.7-1
+- Updated to 1.2.7 (RHBZ #1258669 / CVE-2015-5723)
+- Updated autoloader to load dependencies after self registration
+
+* Sat Jun 27 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.6-2
+- Updated autoloader with trailing separator
+
+* Wed Jun 24 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.6-1
+- Updated to 1.2.6 (RHBZ #1211816)
+- Added autoloader
+
+* Sun Dec 28 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.3-1
+- Updated to 1.2.3 (BZ #1176942)
+
+* Sun Oct 19 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.1-1
+- Updated to 1.2.1 (BZ #1146910)
+- %%license usage
+
+* Mon Sep 29 2014 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
+- update to 1.2.1
+
+* Thu Jul 17 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.0-2
+- Removed skipping of test (php-phpunit-PHPUnit-MockObject patched to fix issue)
+
+* Tue Jul 15 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.0-1
+- Updated to 1.2.0 (BZ #1116887)
+
+* Fri Jun 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.2-5.20131220gita11349d
+- Added php-composer(%%{composer_vendor}/%%{composer_project}) virtual provide
+- Added option to build without tests ("--without tests")
+- Updated dependencies to use php-composer virtual provides
+
+* Sat Jan 11 2014 Remi Collet <rpms@famillecollet.com> 1.1.2-3.20131220gita11349d
+- backport for remi repo
+
+* Mon Jan 06 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.2-3.20131220gita11349d
+- Minor syntax changes
+
+* Fri Jan 03 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.2-2.20131220gita11349d
+- Conditional %%{?dist}
+- Added conflict w/ PEAR-based DoctrineCommon pkg (version < 2.4)
+
+* Mon Dec 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.2-1.20131220gita11349d
+- Initial package