summaryrefslogtreecommitdiffstats
path: root/php-doctrine-annotations.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-annotations.spec')
-rw-r--r--php-doctrine-annotations.spec23
1 files changed, 15 insertions, 8 deletions
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
index eaa70eb..f866f6f 100644
--- a/php-doctrine-annotations.spec
+++ b/php-doctrine-annotations.spec
@@ -15,8 +15,8 @@
%global github_owner doctrine
%global github_name annotations
-%global github_version 1.13.3
-%global github_commit 648b0343343565c4a056bfc8392201385e8d89f0
+%global github_version 1.14.1
+%global github_commit 9e034d7a70032d422169f27d8759e8d84abb4f51
%global composer_vendor doctrine
%global composer_project annotations
@@ -26,10 +26,10 @@
# "doctrine/cache": "^1.11 || ^2."
%global cache_min_ver 1.11
%global cache_max_ver 3
-# "doctrine/lexer": "1.*"
+# "doctrine/lexer": "^1 || ^2"
# NOTE: Min version not 1.0 because autoloader required
%global lexer_min_ver 1.0.1
-%global lexer_max_ver 2.0
+%global lexer_max_ver 3
# "psr/cache": "^1 || ^2 || ^3"
%global psr_cache_min_ver 1
# only v1 is available for now
@@ -74,9 +74,9 @@ BuildRequires: php-doctrine-lexer >= %{lexer_min_ver}
BuildRequires: php-psr-cache >= %{psr_cache_min_ver}
BuildRequires: php-symfony4-cache >= %{symfony_min_ver}
%endif
-# "phpunit/phpunit": "^7.5 || ^8.0 || ^9.1.5"
+# "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.1.5
+BuildRequires: phpunit9 >= 9.5
## phpcompatinfo (computed from version 1.10.0)
BuildRequires: php-ctype
@@ -144,7 +144,10 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Common\\Annotations\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
- '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
+ [
+ '%{phpdir}/Doctrine/Common/Lexer2/autoload.php',
+ '%{phpdir}/Doctrine/Common/Lexer/autoload.php',
+ ],
'%{phpdir}/Psr/Cache/autoload.php',
]);
AUTOLOAD
@@ -178,7 +181,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for CMD in "php %{phpunit}" php74 php80 php81 php82; do
+for CMD in "php %{phpunit}" php80 php81 php82; do
if which $CMD; then
set $CMD
$1 ${2:-%{_bindir}/phpunit9} --verbose \
@@ -202,6 +205,10 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 13 2022 Remi Collet <remi@remirepo.net> - 1.14.1-1
+- update to 1.14.1
+- allow doctrine/lexer v2
+
* Mon Jul 4 2022 Remi Collet <remi@remirepo.net> - 1.13.3-1
- update to 1.13.3