summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-17 13:41:43 +0200
committerRemi Collet <remi@remirepo.net>2018-10-17 13:41:43 +0200
commitd9f33775a4a152404907aaf8fb3c9fb809bc9d43 (patch)
tree03d45e5f40a1c876a86e64a90bb2c28bccbb1c10
parent71195395d5d5808978db68a75050f11b9708ea31 (diff)
update to 1.6.0
raise dependency on PHP 7.1 use phpunit6 use range dependencies
-rw-r--r--composer.json11
-rw-r--r--php-doctrine-annotations.spec46
2 files changed, 36 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 1c65f6c..cd5b630 100644
--- a/composer.json
+++ b/composer.json
@@ -13,19 +13,22 @@
{"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
],
"require": {
- "php": ">=5.3.2",
+ "php": "^7.1",
"doctrine/lexer": "1.*"
},
"require-dev": {
"doctrine/cache": "1.*",
- "phpunit/phpunit": "4.*"
+ "phpunit/phpunit": "^6.4"
},
"autoload": {
- "psr-0": { "Doctrine\\Common\\Annotations\\": "lib/" }
+ "psr-4": { "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations" }
+ },
+ "autoload-dev": {
+ "psr-4": { "Doctrine\\Tests\\Common\\Annotations\\": "tests/Doctrine/Tests/Common/Annotations" }
},
"extra": {
"branch-alias": {
- "dev-master": "1.3.x-dev"
+ "dev-master": "1.6.x-dev"
}
}
}
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
index 430b1fd..3c4210f 100644
--- a/php-doctrine-annotations.spec
+++ b/php-doctrine-annotations.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-annotations
#
-# Copyright (c) 2013-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,21 +12,21 @@
%global github_owner doctrine
%global github_name annotations
-%global github_version 1.2.7
-%global github_commit f25c8aab83e0c3e976fd7d19875f198ccf2f7535
+%global github_version 1.6.0
+%global github_commit c7f2050c68a9ab0bdb0f98567ec08d80ea7d24d5
%global composer_vendor doctrine
%global composer_project annotations
-# "php": ">=5.3.2"
-%global php_min_ver 5.3.2
+# "php": "^7.1"
+%global php_min_ver 7.1
# "doctrine/cache": "1.*"
# NOTE: Min version not 1.0 because autoloader required
%global cache_min_ver 1.4.1
%global cache_max_ver 2.0
# "doctrine/lexer": "1.*"
# NOTE: Min version not 1.0 because autoloader required
-%global lexer_min_ver 1.0.1-4
+%global lexer_min_ver 1.0.1
%global lexer_max_ver 2.0
# Build using "--without tests" to disable tests
@@ -36,7 +36,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 4%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: PHP docblock annotations parser library
Group: Development/Libraries
@@ -53,12 +53,16 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires:(php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
+BuildRequires:(php-composer(doctrine/lexer) >= %{lexer_min_ver} with php-composer(doctrine/lexer) < %{lexer_max_ver})
+%else
+BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(doctrine/lexer) < %{lexer_max_ver}
-#BuildRequires: php-composer(doctrine/lexer) >= %%{lexer_min_ver}
-BuildRequires: php-doctrine-lexer >= %{lexer_min_ver}
+BuildRequires: php-composer(doctrine/lexer) >= %{lexer_min_ver}
+%endif
+BuildRequires: phpunit6
## phpcompatinfo (computed from version 1.2.7)
BuildRequires: php-ctype
BuildRequires: php-date
@@ -73,10 +77,13 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-#Requires: php-composer(doctrine/lexer) >= %%{lexer_min_ver}
-Requires: php-doctrine-lexer >= %{lexer_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(doctrine/lexer) >= %{lexer_min_ver} with php-composer(doctrine/lexer) < %{lexer_max_ver})
+%else
Requires: php-composer(doctrine/lexer) < %{lexer_max_ver}
-# phpcompatinfo (computed from version 1.2.7)
+Requires: php-composer(doctrine/lexer) >= %{lexer_min_ver}
+%endif
+# phpcompatinfo (computed from version 1.6.0)
Requires: php-ctype
Requires: php-date
Requires: php-json
@@ -141,10 +148,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose \
+ $PHP_EXEC %{_bindir}/phpunit6 --verbose \
-d pcre.recursion_limit=10000 \
--bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -165,6 +171,12 @@ exit $RETURN_CODE
%changelog
+* Wed Oct 17 2018 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- raise dependency on PHP 7.1
+- use phpunit6
+- use range dependencies
+
* Fri May 12 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.7-4
- Switch autoloader to php-composer(fedora/autoloader)
- Add max versions to build dependencies