summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-26 07:22:31 +0100
committerRemi Collet <remi@remirepo.net>2020-10-26 07:22:31 +0100
commitbddec47c040457b17b3ba87e20a703aaa03b5dc7 (patch)
treea65070fed0bc4bb450d1d737d0ef515ba79b08b1
parent3f48dcc9d981cff5e7fc4168951f4f82c8d9caa9 (diff)
update to 1.11.0
-rw-r--r--composer.json5
-rw-r--r--php-doctrine-annotations.spec16
2 files changed, 14 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 10aae87..2f3318a 100644
--- a/composer.json
+++ b/composer.json
@@ -3,7 +3,7 @@
"type": "library",
"description": "Docblock Annotations Parser",
"keywords": ["annotations", "docblock", "parser"],
- "homepage": "http://www.doctrine-project.org",
+ "homepage": "https://www.doctrine-project.org/projects/annotations.html",
"license": "MIT",
"authors": [
{"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
@@ -19,6 +19,7 @@
},
"require-dev": {
"doctrine/cache": "1.*",
+ "doctrine/coding-standard": "^6.0 || ^8.1",
"phpstan/phpstan": "^0.12.20",
"phpunit/phpunit": "^7.5 || ^9.1.5"
},
@@ -39,7 +40,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.9.x-dev"
+ "dev-master": "1.11.x-dev"
}
}
}
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
index 4a9c332..d65b032 100644
--- a/php-doctrine-annotations.spec
+++ b/php-doctrine-annotations.spec
@@ -15,8 +15,8 @@
%global github_owner doctrine
%global github_name annotations
-%global github_version 1.10.4
-%global github_commit bfe91e31984e2ba76df1c1339681770401ec262f
+%global github_version 1.11.0
+%global github_commit 88fb6fb1dae011de24dd6b632811c1ff5c2928f5
%global composer_vendor doctrine
%global composer_project annotations
@@ -56,17 +56,20 @@ BuildRequires: php(language) >= %{php_min_ver}
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires:(php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
BuildRequires:(php-composer(doctrine/lexer) >= %{lexer_min_ver} with php-composer(doctrine/lexer) < %{lexer_max_ver})
-# "phpunit/phpunit": "^7.5 || ^9.1.5"
-%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.1.5
%else
BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
BuildRequires: php-composer(doctrine/lexer) < %{lexer_max_ver}
BuildRequires: php-composer(doctrine/lexer) >= %{lexer_min_ver}
+# "phpunit/phpunit": "^7.5 || ^9.1.5"
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.1.5
+%else
%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7 >= 7.5
%endif
+%endif
## phpcompatinfo (computed from version 1.10.0)
BuildRequires: php-ctype
@@ -178,6 +181,9 @@ exit $RETURN_CODE
%changelog
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+
* Wed Aug 12 2020 Remi Collet <remi@remirepo.net> - 1.10.4-1
- update to 1.10.4
- switch to phpunit9