summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-19 17:23:03 +0200
committerRemi Collet <remi@remirepo.net>2019-08-19 17:23:03 +0200
commitbc62be0ac95baa377f763c7bc781cf09c93b13d3 (patch)
tree5353bfc4a7862a96fc8cf8658b9848753ef76894
parentffeb50d95cba44af2f81784556ccb31768c66fdc (diff)
- update to 1.7.0
- switch to phpunit7
-rw-r--r--composer.json15
-rw-r--r--php-doctrine-annotations.spec12
2 files changed, 20 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index cd5b630..4b24c46 100644
--- a/composer.json
+++ b/composer.json
@@ -18,17 +18,26 @@
},
"require-dev": {
"doctrine/cache": "1.*",
- "phpunit/phpunit": "^6.4"
+ "phpunit/phpunit": "^7.5@dev"
+ },
+ "config": {
+ "sort-packages": true
},
"autoload": {
"psr-4": { "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations" }
},
"autoload-dev": {
- "psr-4": { "Doctrine\\Tests\\Common\\Annotations\\": "tests/Doctrine/Tests/Common/Annotations" }
+ "psr-4": {
+ "Doctrine\\Performance\\Common\\Annotations\\": "tests/Doctrine/Performance/Common/Annotations",
+ "Doctrine\\Tests\\Common\\Annotations\\": "tests/Doctrine/Tests/Common/Annotations"
+ },
+ "files": [
+ "tests/Doctrine/Tests/Common/Annotations/Fixtures/SingleClassLOC1000.php"
+ ]
},
"extra": {
"branch-alias": {
- "dev-master": "1.6.x-dev"
+ "dev-master": "1.7.x-dev"
}
}
}
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
index 5f8fcd3..6deaacd 100644
--- a/php-doctrine-annotations.spec
+++ b/php-doctrine-annotations.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name annotations
-%global github_version 1.6.1
-%global github_commit 53120e0eb10355388d6ccbe462f1fea34ddadb24
+%global github_version 1.7.0
+%global github_commit fa4c4e861e809d6a1103bd620cce63ed91aedfeb
%global composer_vendor doctrine
%global composer_project annotations
@@ -61,7 +61,7 @@ BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
BuildRequires: php-composer(doctrine/lexer) < %{lexer_max_ver}
BuildRequires: php-composer(doctrine/lexer) >= %{lexer_min_ver}
%endif
-BuildRequires: phpunit6
+BuildRequires: phpunit7
## phpcompatinfo (computed from version 1.6.1)
BuildRequires: php-ctype
BuildRequires: php-date
@@ -150,7 +150,7 @@ BOOTSTRAP
RETURN_CODE=0
for PHP_EXEC in "" php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit6 --verbose \
+ $PHP_EXEC %{_bindir}/phpunit7 --verbose \
-d pcre.recursion_limit=10000 \
--bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -171,6 +171,10 @@ exit $RETURN_CODE
%changelog
+* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0
+- switch to phpunit7
+
* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.6.1-1
- update to 1.6.1