summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-04 07:51:01 +0200
committerRemi Collet <remi@php.net>2022-07-04 07:51:01 +0200
commit78624e64bb39f61e73e4361733b66c511d29ebfb (patch)
tree3d533c9c54fb947852572bcbf8134817ac9d6d54
parente396eeb777ee6d93ba3d18179de42daea425022c (diff)
update to 1.13.3
-rw-r--r--composer.json53
-rw-r--r--php-doctrine-annotations.spec11
2 files changed, 46 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 00d0231..b4dfbd3 100644
--- a/composer.json
+++ b/composer.json
@@ -1,17 +1,36 @@
{
"name": "doctrine/annotations",
- "type": "library",
"description": "Docblock Annotations Parser",
- "keywords": ["annotations", "docblock", "parser"],
- "homepage": "https://www.doctrine-project.org/projects/annotations.html",
"license": "MIT",
+ "type": "library",
+ "keywords": [
+ "annotations",
+ "docblock",
+ "parser"
+ ],
"authors": [
- {"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
- {"name": "Roman Borschel", "email": "roman@code-factory.org"},
- {"name": "Benjamin Eberlei", "email": "kontakt@beberlei.de"},
- {"name": "Jonathan Wage", "email": "jonwage@gmail.com"},
- {"name": "Johannes Schmitt", "email": "schmittjoh@gmail.com"}
+ {
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@gmail.com"
+ },
+ {
+ "name": "Roman Borschel",
+ "email": "roman@code-factory.org"
+ },
+ {
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
+ },
+ {
+ "name": "Jonathan Wage",
+ "email": "jonwage@gmail.com"
+ },
+ {
+ "name": "Johannes Schmitt",
+ "email": "schmittjoh@gmail.com"
+ }
],
+ "homepage": "https://www.doctrine-project.org/projects/annotations.html",
"require": {
"php": "^7.1 || ^8.0",
"ext-tokenizer": "*",
@@ -21,15 +40,15 @@
"require-dev": {
"doctrine/cache": "^1.11 || ^2.0",
"doctrine/coding-standard": "^6.0 || ^8.1",
- "phpstan/phpstan": "^0.12.20",
+ "phpstan/phpstan": "^1.4.10 || ^1.8.0",
"phpunit/phpunit": "^7.5 || ^8.0 || ^9.1.5",
- "symfony/cache": "^4.4 || ^5.2"
- },
- "config": {
- "sort-packages": true
+ "symfony/cache": "^4.4 || ^5.2",
+ "vimeo/psalm": "^4.10"
},
"autoload": {
- "psr-4": { "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations" }
+ "psr-4": {
+ "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations"
+ }
},
"autoload-dev": {
"psr-4": {
@@ -40,5 +59,11 @@
"tests/Doctrine/Tests/Common/Annotations/Fixtures/functions.php",
"tests/Doctrine/Tests/Common/Annotations/Fixtures/SingleClassLOC1000.php"
]
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "sort-packages": true
}
}
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
index 0afe37c..eaa70eb 100644
--- a/php-doctrine-annotations.spec
+++ b/php-doctrine-annotations.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-annotations
#
-# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -15,8 +15,8 @@
%global github_owner doctrine
%global github_name annotations
-%global github_version 1.13.2
-%global github_commit 5b668aef16090008790395c02c893b1ba13f7e08
+%global github_version 1.13.3
+%global github_commit 648b0343343565c4a056bfc8392201385e8d89f0
%global composer_vendor doctrine
%global composer_project annotations
@@ -178,7 +178,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for CMD in "php %{phpunit}" php73 php74 php80 php81; do
+for CMD in "php %{phpunit}" php74 php80 php81 php82; do
if which $CMD; then
set $CMD
$1 ${2:-%{_bindir}/phpunit9} --verbose \
@@ -202,6 +202,9 @@ exit $RETURN_CODE
%changelog
+* Mon Jul 4 2022 Remi Collet <remi@remirepo.net> - 1.13.3-1
+- update to 1.13.3
+
* Fri Aug 6 2021 Remi Collet <remi@remirepo.net> - 1.13.2-1
- update to 1.13.2