summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-22 11:26:44 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-22 11:26:44 +0200
commit5e36235d01f3c379a32766695c4f3a1be909a1a3 (patch)
treef78f9af106ff3ab722cccc0513bd71b76f128164
parent04af58711d3d7564bd4c008745ad42bf63ba76dd (diff)
php-doctrine-annotations: rawhide changes
-rw-r--r--php-doctrine-annotations.spec75
1 files changed, 53 insertions, 22 deletions
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
index 27da5fc..c850400 100644
--- a/php-doctrine-annotations.spec
+++ b/php-doctrine-annotations.spec
@@ -1,22 +1,39 @@
-%global github_owner doctrine
-%global github_name annotations
-%global github_version 1.1.2
-%global github_commit a11349d39d85bef75a71bd69bd604ac4fb993f03
+#
+# RPM spec file for php-doctrine-annotations
+#
+# Copyright (c) 2013-2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner doctrine
+%global github_name annotations
+%global github_version 1.1.2
+%global github_commit a11349d39d85bef75a71bd69bd604ac4fb993f03
# Additional commits after v1.1.2 tag
-%global github_release .20131220git%(c=%{github_commit}; echo ${c:0:7})
+%global github_release .20131220git%(c=%{github_commit}; echo ${c:0:7})
+
+%global composer_vendor doctrine
+%global composer_project annotations
# "php": ">=5.3.2"
-%global php_min_ver 5.3.2
+%global php_min_ver 5.3.2
# "doctrine/cache": "1.*"
-%global cache_min_ver 1.0
-%global cache_max_ver 2.0
+%global cache_min_ver 1.0
+%global cache_max_ver 2.0
# "doctrine/lexer": "1.*"
-%global lexer_min_ver 1.0
-%global lexer_max_ver 2.0
+%global lexer_min_ver 1.0
+%global lexer_max_ver 2.0
+
+# Build using "--without tests" to disable tests
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-Name: php-%{github_owner}-%{github_name}
+Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 5%{?github_release}%{?dist}
Summary: PHP docblock annotations parser library
Group: Development/Libraries
@@ -26,13 +43,14 @@ Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{githu
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+%if %{with_tests}
# For tests
-BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-doctrine-cache >= %{cache_min_ver}
-BuildRequires: php-doctrine-cache < %{cache_max_ver}
-BuildRequires: php-doctrine-lexer >= %{lexer_min_ver}
-BuildRequires: php-doctrine-lexer < %{lexer_max_ver}
-BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
+BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
+BuildRequires: php-composer(doctrine/lexer) >= %{lexer_min_ver}
+BuildRequires: php-composer(doctrine/lexer) < %{lexer_max_ver}
+BuildRequires: php-phpunit-PHPUnit
# For tests: phpcompatinfo (computed from v1.1.2 git commit a11349d39d85bef75a71bd69bd604ac4fb993f03)
BuildRequires: php-ctype
BuildRequires: php-date
@@ -41,10 +59,11 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
BuildRequires: php-tokenizer
+%endif
-Requires: php(language) >= %{php_min_ver}
-Requires: php-doctrine-lexer >= %{lexer_min_ver}
-Requires: php-doctrine-lexer < %{lexer_max_ver}
+Requires: php(language) >= %{php_min_ver}
+Requires: php-composer(doctrine/lexer) >= %{lexer_min_ver}
+Requires: php-composer(doctrine/lexer) < %{lexer_max_ver}
# phpcompatinfo (computed from v1.1.2 git commit a11349d39d85bef75a71bd69bd604ac4fb993f03)
Requires: php-ctype
Requires: php-date
@@ -54,6 +73,9 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
# Extracted from Doctrine Common as of version 2.4
Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
@@ -62,7 +84,7 @@ Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
%prep
-%setup -q -n %{github_name}-%{github_commit}
+%setup -qn %{github_name}-%{github_commit}
%build
@@ -76,6 +98,7 @@ cp -rp lib/* %{buildroot}/%{_datadir}/php/
%check
+%if %{with_tests}
# Create tests' init
cat > tests/Doctrine/Tests/TestInit.php <<'TESTINIT'
<?php
@@ -95,6 +118,9 @@ TESTINIT
sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%{_bindir}/phpunit --include-path ./lib:./tests -d date.timezone="UTC"
+%else
+: Tests skipped
+%endif
%clean
@@ -108,6 +134,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.2-5.20131220gita11349d
+- Added php-composer(%%{composer_vendor}/%%{composer_project}) virtual provide
+- Added option to build without tests ("--without tests")
+- Updated dependencies to use php-composer virtual provides
+
* Sat Jan 11 2014 Remi Collet <rpms@famillecollet.com> 1.1.2-3.20131220gita11349d
- backport for remi repo