summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-11 15:29:33 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-11 15:29:33 +0100
commit08b5294c55837a3dcb77ae23c01dc6524b613eaa (patch)
treeeee1baecccfafc6e707edc203222eb10d47d7659
php-doctrine-annotations: import from rawhide
-rw-r--r--php-doctrine-annotations.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/php-doctrine-annotations.spec b/php-doctrine-annotations.spec
new file mode 100644
index 0000000..1d04194
--- /dev/null
+++ b/php-doctrine-annotations.spec
@@ -0,0 +1,112 @@
+%global github_owner doctrine
+%global github_name annotations
+%global github_version 1.1.2
+%global github_commit a11349d39d85bef75a71bd69bd604ac4fb993f03
+# Additional commits after v1.1.2 tag
+%global github_release .20131220git%(c=%{github_commit}; echo ${c:0:7})
+
+# "php": ">=5.3.2"
+%global php_min_ver 5.3.2
+# "doctrine/cache": "1.*"
+%global cache_min_ver 1.0
+%global cache_max_ver 2.0
+# "doctrine/lexer": "1.*"
+%global lexer_min_ver 1.0
+%global lexer_max_ver 2.0
+
+Name: php-%{github_owner}-%{github_name}
+Version: %{github_version}
+Release: 3%{?github_release}%{?dist}
+Summary: PHP docblock annotations parser library
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+# For tests
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-doctrine-cache >= %{cache_min_ver}
+BuildRequires: php-doctrine-cache < %{cache_max_ver}
+BuildRequires: php-doctrine-lexer >= %{lexer_min_ver}
+BuildRequires: php-doctrine-lexer < %{lexer_max_ver}
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+# For tests: phpcompatinfo (computed from v1.1.2 git commit a11349d39d85bef75a71bd69bd604ac4fb993f03)
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-json
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+BuildRequires: php-tokenizer
+
+Requires: php(language) >= %{php_min_ver}
+Requires: php-doctrine-lexer >= %{lexer_min_ver}
+Requires: php-doctrine-lexer < %{lexer_max_ver}
+# phpcompatinfo (computed from v1.1.2 git commit a11349d39d85bef75a71bd69bd604ac4fb993f03)
+Requires: php-ctype
+Requires: php-date
+Requires: php-json
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+Requires: php-tokenizer
+
+# Extracted from Doctrine Common as of version 2.4
+Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
+
+%description
+%{summary} (extracted from Doctrine Common).
+
+
+%prep
+%setup -q -n %{github_name}-%{github_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -p %{buildroot}/%{_datadir}/php
+cp -rp lib/* %{buildroot}/%{_datadir}/php/
+
+
+%check
+# Create tests' init
+cat > tests/Doctrine/Tests/TestInit.php <<'TESTINIT'
+<?php
+namespace Doctrine\Tests;
+
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', str_replace('_', '/', $class)).'.php';
+ @include_once $src;
+});
+
+\Doctrine\Common\Annotations\AnnotationRegistry::registerAutoloadNamespace(
+ 'Doctrine\Tests\Common\Annotations\Fixtures', __DIR__ . '/../../'
+);
+TESTINIT
+
+# Create PHPUnit config w/ colors turned off
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
+
+%{_bindir}/phpunit --include-path ./lib:./tests -d date.timezone="UTC"
+
+
+%files
+%doc LICENSE *.md composer.json
+%{_datadir}/php/Doctrine/Common/Annotations
+
+
+%changelog
+* Mon Jan 06 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.2-3.20131220gita11349d
+- Minor syntax changes
+
+* Fri Jan 03 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.2-2.20131220gita11349d
+- Conditional %%{?dist}
+- Added conflict w/ PEAR-based DoctrineCommon pkg (version < 2.4)
+
+* Mon Dec 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.2-1.20131220gita11349d
+- Initial package