summaryrefslogtreecommitdiffstats
path: root/php-di.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-24 15:45:00 +0200
committerRemi Collet <remi@remirepo.net>2017-04-24 15:45:00 +0200
commit17dca360f08cad3beb7a73685272fdcf995d6bba (patch)
treecc78ccc6edee33b4d93f55c43a759ca435595d63 /php-di.spec
parentccdebd96b76b20dfa89439d3b13d4f3b64bc13f8 (diff)
v5.4.3 (backported from Fedora)
Diffstat (limited to 'php-di.spec')
-rw-r--r--php-di.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-di.spec b/php-di.spec
index 498c88d..5186a02 100644
--- a/php-di.spec
+++ b/php-di.spec
@@ -12,8 +12,8 @@
%global github_owner PHP-DI
%global github_name PHP-DI
-%global github_version 5.4.2
-%global github_commit bbe2ed4b48e5b832436bf50928c30af8aedf61f8
+%global github_version 5.4.3
+%global github_commit 8ecded470bb0255c93f2996f78bb3b644c06599a
%global composer_vendor php-di
%global composer_project php-di
@@ -60,7 +60,7 @@ License: MIT
URL: http://php-di.org/
# GitHub export does not include tests.
-# Run php-di-invoker-get-source.sh to create full source.
+# Run php-di-get-source.sh to create full source.
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
@@ -89,7 +89,7 @@ BuildRequires: php-composer(phpunit/phpunit)
%if 0%{?fedora} >= 26
BuildRequires: phpunit6
%endif
-## phpcompatinfo (computed from version 5.4.0)
+## phpcompatinfo (computed from version 5.4.3)
BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -108,7 +108,7 @@ Requires: php-composer(php-di/phpdoc-reader) < %{di_phpdoc_reader_max_ver}
Requires: php-composer(php-di/phpdoc-reader) >= %{di_phpdoc_reader_min_ver}
Requires: php-composer(psr/container) < %{psr_container_max_ver}
Requires: php-composer(psr/container) >= %{psr_container_min_ver}
-# phpcompatinfo (computed from version 5.4.0)
+# phpcompatinfo (computed from version 5.4.3)
Requires: php-json
Requires: php-pcre
Requires: php-reflection
@@ -207,9 +207,9 @@ sed -e '/@test/d' \
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71; do
+for PHP_EXEC in php php70 php71; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- for PHPUNIT in phpunit phpunit6; do
+ for PHPUNIT in phpunit; do
PHPUNIT=$(which $PHPUNIT) || :
if [ -n "$PHPUNIT" ]; then
$PHP_EXEC $PHPUNIT --bootstrap bootstrap.php --verbose || RETURN_CODE=1
@@ -233,6 +233,9 @@ exit $RETURN_CODE
%changelog
+* Fri Apr 14 2017 Shawn Iwinski <shawn@iwin.ski> - 5.4.3-1
+- Update to 5.4.3 (RHBZ #1442382)
+
* Sun Apr 02 2017 Shawn Iwinski <shawn@iwin.ski> - 5.4.2-1
- Update to 5.4.2 (RHBZ #1435627)
- Add max versions to BuildRequires