summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 18:38:58 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 18:38:58 +0200
commit935619b0e2c8e4b429c9ee1221a1efb06960626b (patch)
tree6cbee775f62c128659047446d8adb498ce1a4394
parent442486dc7e67fab0e5e517123ed2ad4d0a24f68c (diff)
php-di: 5.3.0
-rw-r--r--composer.json49
-rw-r--r--php-di.spec18
2 files changed, 61 insertions, 6 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..01808c2
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,49 @@
+{
+ "name": "php-di/php-di",
+ "type": "library",
+ "description": "The dependency injection container for humans",
+ "keywords": ["di", "dependency injection", "container"],
+ "homepage": "http://php-di.org/",
+ "license": "MIT",
+ "autoload": {
+ "psr-4": {
+ "DI\\": "src/DI/"
+ },
+ "files": [
+ "src/DI/functions.php"
+ ]
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "DI\\Test\\IntegrationTest\\": "tests/IntegrationTest/",
+ "DI\\Test\\UnitTest\\": "tests/UnitTest/"
+ }
+ },
+ "scripts": {
+ "test": "phpunit"
+ },
+ "require": {
+ "php": ">=5.5.0",
+ "container-interop/container-interop": "~1.0",
+ "php-di/invoker": "^1.1.1",
+ "php-di/phpdoc-reader": "^2.0.1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.5",
+ "mnapoli/phpunit-easymock": "~0.2.0",
+ "doctrine/cache": "~1.4",
+ "doctrine/annotations": "~1.2",
+ "ocramius/proxy-manager": "~1.0|~2.0"
+ },
+ "replace": {
+ "mnapoli/php-di": "*"
+ },
+ "provide": {
+ "container-interop/container-interop-implementation": "^1.0"
+ },
+ "suggest": {
+ "doctrine/cache": "Install it if you want to use the cache (version ~1.4)",
+ "doctrine/annotations": "Install it if you want to use annotations (version ~1.2)",
+ "ocramius/proxy-manager": "Install it if you want to use lazy injection (version ~1.0 or ~2.0)"
+ }
+}
diff --git a/php-di.spec b/php-di.spec
index 2669305..9c700e7 100644
--- a/php-di.spec
+++ b/php-di.spec
@@ -12,14 +12,14 @@
%global github_owner PHP-DI
%global github_name PHP-DI
-%global github_version 5.2.2
-%global github_commit f574bcc841201ab04587b1c6da1234d4044f67d8
+%global github_version 5.3.0
+%global github_commit 854a6d8f54e2146f0a34f0a28f0adea688b634a3
%global composer_vendor php-di
%global composer_project php-di
-# "php": ">=5.4.0"
-%global php_min_ver 5.4.0
+# "php": ">=5.5.0"
+%global php_min_ver 5.5.0
# "container-interop/container-interop": "~1.0"
%global container_interop_min_ver 1.0
%global container_interop_max_ver 2.0
@@ -38,9 +38,9 @@
# "php-di/phpdoc-reader": "^2.0.1"
%global di_phpdoc_reader_min_ver 2.0.1
%global di_phpdoc_reader_max_ver 3.0
-# "ocramius/proxy-manager": "~1.0"
+# "ocramius/proxy-manager": "~1.0|~2.0"
%global proxy_manager_min_ver 1.0
-%global proxy_manager_max_ver 2.0
+%global proxy_manager_max_ver 3.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -115,6 +115,7 @@ Suggests: php-composer(ocramius/proxy-manager) < %{proxy_mana
Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+Provides: php-composer(container-interop/container-interop-implementation) = 1.0
%description
%{summary}.
@@ -218,6 +219,11 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 5.3.0-1
+- update to 5.3.0
+- raise dependency on php >=5.5.0
+- allow ocramius/proxy-manager 2.0
+
* Fri Mar 11 2016 Shawn Iwinski <shawn@iwin.ski> - 5.2.2-1
- Updated to 5.2.2 (RHBZ #1298928)