summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 10:34:39 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 10:34:39 +0200
commit7e0601d1db920f7279ed85158dfae57ad03b3a1b (patch)
treecff0100f4493eea19876ef3b8093b74f140acb4a
parent55d5049d933ae890b888c9344037e825469f39ce (diff)
v5.4.6 From Fedora
-rw-r--r--composer.json7
l---------makesrc.sh1
-rw-r--r--php-di.spec14
3 files changed, 14 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index dba3c73..0f22f9c 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,8 @@
},
"require": {
"php": ">=5.5.0",
- "container-interop/container-interop": "~1.0",
+ "container-interop/container-interop": "~1.2",
+ "psr/container": "~1.0",
"php-di/invoker": "^1.3.2",
"php-di/phpdoc-reader": "^2.0.1"
},
@@ -33,13 +34,15 @@
"mnapoli/phpunit-easymock": "~0.2.0",
"doctrine/cache": "~1.4",
"doctrine/annotations": "~1.2",
+ "phpbench/phpbench": "@dev",
"ocramius/proxy-manager": "~1.0|~2.0"
},
"replace": {
"mnapoli/php-di": "*"
},
"provide": {
- "container-interop/container-interop-implementation": "^1.0"
+ "container-interop/container-interop-implementation": "^1.0",
+ "psr/container-implementation": "^1.0"
},
"suggest": {
"doctrine/cache": "Install it if you want to use the cache (version ~1.4)",
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..dd3973f
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-di-get-source.sh \ No newline at end of file
diff --git a/php-di.spec b/php-di.spec
index 03d4af7..85a6613 100644
--- a/php-di.spec
+++ b/php-di.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-di
#
-# Copyright (c) 2016-2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner PHP-DI
%global github_name PHP-DI
-%global github_version 5.4.3
-%global github_commit 8ecded470bb0255c93f2996f78bb3b644c06599a
+%global github_version 5.4.6
+%global github_commit 3f9255659595f3e289f473778bb6c51aa72abbbd
%global composer_vendor php-di
%global composer_project php-di
@@ -52,10 +52,9 @@
Name: %{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 6%{?github_release}%{?dist}
Summary: The dependency injection container for humans
-Group: Development/Libraries
License: MIT
URL: http://php-di.org/
@@ -210,7 +209,7 @@ sed -e '/@test/d' \
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php70 php71 php72; do
+for PHP_EXEC in php php71 php72 php73; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
for PHPUNIT in phpunit; do
PHPUNIT=$(which $PHPUNIT) || :
@@ -236,6 +235,9 @@ exit $RETURN_CODE
%changelog
+* Fri May 10 2019 Shawn Iwinski <shawn@iwin.ski> - 5.4.6-1
+- Update to 5.4.6
+
* Tue Oct 31 2017 Remi Collet <remi@remirepo.net> - 5.4.3-2
- fix FTBFS from Koschei, add upstream patch for PHP 7.2