summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-02 14:46:11 +0100
committerRemi Collet <remi@php.net>2023-03-02 14:46:11 +0100
commita38db89484f0615a1173accbae6a926390fe59a6 (patch)
treea08808485c322fbe131eb9747a898ba177104c7f
parent4f20f2cc96cd60a5a6ebc7feac2f49729ce5b29f (diff)
update to 1.0.4
-rw-r--r--composer.json5
-rw-r--r--php-dasprid-enum.spec21
2 files changed, 13 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index b3d745a..133e279 100644
--- a/composer.json
+++ b/composer.json
@@ -14,9 +14,12 @@
"enum",
"map"
],
+ "require": {
+ "php": ">=7.1 <9.0"
+ },
"require-dev": {
"phpunit/phpunit": "^7 | ^8 | ^9",
- "squizlabs/php_codesniffer": "^3.4"
+ "squizlabs/php_codesniffer": "*"
},
"autoload": {
"psr-4": {
diff --git a/php-dasprid-enum.spec b/php-dasprid-enum.spec
index 0d719ca..2abd0af 100644
--- a/php-dasprid-enum.spec
+++ b/php-dasprid-enum.spec
@@ -1,14 +1,14 @@
# remirepo/fedora spec file for php-dasprid-enum
#
-# Copyright (c) 2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2019-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%bcond_without tests
-%global gh_commit 5abf82f213618696dda8e3bf6f64dd042d8542b2
+%global gh_commit 8e6b6ea76eabbf19ea2bf5b67b98e1860474012f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner DASPRiD
%global gh_project Enum
@@ -22,11 +22,11 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.3
+Version: 1.0.4
Release: 1%{?dist}
Summary: PHP enum implementation
-License: BSD
+License: BSD-2-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -39,13 +39,7 @@ BuildRequires: php-spl
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^7 | ^8 | ^9",
# "squizlabs/php_codesniffer": "^3.4"
-# remirepo:1
-%if 0%{?fedora} >= 32
%global phpunit %{_bindir}/phpunit9
-# remirepo:3
-%else
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: %{phpunit}
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -104,7 +98,7 @@ require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmd in "php %{phpunit}" php80 php81 php82; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -126,6 +120,9 @@ exit $ret
%changelog
+* Thu Mar 2 2023 Remi Collet <remi@remirepo.net> - 1.0.4-1
+- update to 1.0.4
+
* Mon Oct 5 2020 Remi Collet <remi@remirepo.net> - 1.0.3-1
- update to 1.0.3