summaryrefslogtreecommitdiffstats
path: root/php-consolidation-output-formatters.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-consolidation-output-formatters.spec')
-rw-r--r--php-consolidation-output-formatters.spec27
1 files changed, 26 insertions, 1 deletions
diff --git a/php-consolidation-output-formatters.spec b/php-consolidation-output-formatters.spec
index 1c4bf4a..303f5d3 100644
--- a/php-consolidation-output-formatters.spec
+++ b/php-consolidation-output-formatters.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-consolidation-output-formatters, from
#
# Fedora spec file for php-consolidation-output-formatters
#
@@ -39,6 +40,7 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -112,6 +114,8 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}/Consolidation/OutputFormatters
cp -rp src/* %{buildroot}%{phpdir}/Consolidation/OutputFormatters/
@@ -130,13 +134,31 @@ $fedoraClassLoader =
$fedoraClassLoader->addPrefix('Consolidation\\TestUtils\\', __DIR__.'/tests-psr0');
BOOTSTRAP
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --bootstrap bootstrap.php || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --bootstrap bootstrap.php || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+ %{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+fi
+exit $ret
%else
: Tests skipped
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -146,5 +168,8 @@ BOOTSTRAP
%changelog
+* Thu Jul 21 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- backport for remi repository
+
* Tue Jul 19 2016 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-1
- Initial package