summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 12:24:56 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 12:24:56 +0200
commit6f456ccb1a9adb9de7f490c522ee0f6c948562d8 (patch)
treef1a213a7b8f0e6d63a365d4190e0581f87805dfa
parent4b7fd425cd05ed09724f5f6b6b3d44d8f7a4437b (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json35
-rw-r--r--php-consolidation-log.spec1
4 files changed, 47 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..b6ba001
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "consolidation/log",
+ "description": "Improved Psr-3 / Psr\\Log logger based on Symfony Console components.",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Greg Anderson",
+ "email": "greg.1.anderson@greenknowe.org"
+ }
+ ],
+ "autoload":{
+ "psr-4":{
+ "Consolidation\\Log\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Consolidation\\TestUtils\\": "tests/src"
+ }
+ },
+ "require": {
+ "php": ">=5.5.0",
+ "psr/log": "~1.0",
+ "symfony/console": "~2.5|~3.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "4.*",
+ "squizlabs/php_codesniffer": "2.*"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.x-dev"
+ }
+ }
+}
diff --git a/php-consolidation-log.spec b/php-consolidation-log.spec
index 2d7350d..995534b 100644
--- a/php-consolidation-log.spec
+++ b/php-consolidation-log.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-consolidation-log
#
# Fedora spec file for php-consolidation-log
#