summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-23 10:29:49 +0100
committerRemi Collet <remi@remirepo.net>2021-03-23 10:29:49 +0100
commit05e6866c5f7b5ab807ee13523fd0a3a1745ea4e3 (patch)
tree487f8bc9eb8f197e33fc306b061401902b449b30
parent02d9475fd43440f84a817e9181197374d09a144a (diff)
update to 2.0.2
switch to phpunit9 with yoast/phpunit-polyfills
-rw-r--r--composer.json58
-rw-r--r--php-consolidation-log.spec37
2 files changed, 34 insertions, 61 deletions
diff --git a/composer.json b/composer.json
index 708e6d9..1edc4c5 100644
--- a/composer.json
+++ b/composer.json
@@ -19,21 +19,20 @@
}
},
"require": {
- "php": ">=5.4.5",
+ "php": ">=7.1.3",
"psr/log": "^1.0",
- "symfony/console": "^2.8|^3|^4"
+ "symfony/console": "^4|^5"
},
"require-dev": {
- "phpunit/phpunit": "^6",
- "g1a/composer-test-scenarios": "^3",
- "php-coveralls/php-coveralls": "^1",
- "squizlabs/php_codesniffer": "^2"
+ "phpunit/phpunit": ">=7.5.20",
+ "squizlabs/php_codesniffer": "^3",
+ "yoast/phpunit-polyfills": "^0.2.0"
},
"minimum-stability": "stable",
"scripts": {
"cs": "phpcs -n --standard=PSR2 src",
"cbf": "phpcbf -n --standard=PSR2 src",
- "unit": "phpunit",
+ "unit": "phpunit --colors=always",
"lint": [
"find src -name '*.php' -print0 | xargs -0 -n1 php -l",
"find tests/src -name '*.php' -print0 | xargs -0 -n1 php -l"
@@ -45,56 +44,15 @@
]
},
"extra": {
- "scenarios": {
- "symfony4": {
- "require": {
- "symfony/console": "^4.0"
- },
- "config": {
- "platform": {
- "php": "7.1.3"
- }
- }
- },
- "symfony2": {
- "require": {
- "symfony/console": "^2.8"
- },
- "require-dev": {
- "phpunit/phpunit": "^4.8.36"
- },
- "remove": [
- "php-coveralls/php-coveralls"
- ],
- "config": {
- "platform": {
- "php": "5.4.8"
- }
- }
- },
- "phpunit4": {
- "require-dev": {
- "phpunit/phpunit": "^4.8.36"
- },
- "remove": [
- "php-coveralls/php-coveralls"
- ],
- "config": {
- "platform": {
- "php": "5.4.8"
- }
- }
- }
- },
"branch-alias": {
- "dev-master": "1.x-dev"
+ "dev-main": "2.x-dev"
}
},
"config": {
"optimize-autoloader": true,
"sort-packages": true,
"platform": {
- "php": "7.0.8"
+ "php": "7.2.28"
}
}
}
diff --git a/php-consolidation-log.spec b/php-consolidation-log.spec
index e100f23..facd095 100644
--- a/php-consolidation-log.spec
+++ b/php-consolidation-log.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-consolidation-log
#
-# Copyright (c) 2016-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner consolidation
%global github_name log
-%global github_version 2.0.1
-%global github_commit ba0bf6af1fbd09ed4dc18fc2f27b12ceff487cbf
+%global github_version 2.0.2
+%global github_commit 82a2aaaa621a7b976e50a745a8d249d5085ee2b1
%global composer_vendor consolidation
%global composer_project log
@@ -28,10 +28,13 @@
%global symfony_min_ver 4.0
%global symfony_max_ver 6.0
-# "phpunit/phpunit": "^6"
-%global phpunit_require phpunit6
-%global phpunit_min_ver 6
-%global phpunit_exec phpunit6
+# "phpunit/phpunit": ">=7.5.20"
+%global phpunit_require phpunit9
+%global phpunit_min_ver 9
+%global phpunit_exec phpunit9
+# "yoast/phpunit-polyfills": "^0.2.0"
+%global polyfills_min_ver 0.2
+%global polyfills_max_ver 1
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -63,10 +66,13 @@ BuildRequires: %{phpunit_require} >= %{phpunit_min_ver}
%if %{with_range_dependencies}
BuildRequires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
BuildRequires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
+BuildRequires: (php-composer(yoast/phpunit-polyfills) >= %{polyfills_min_ver} with php-composer(yoast/phpunit-polyfills) < %{polyfills_max_ver})
%else
BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-symfony4-console >= %{symfony_min_ver}
+BuildRequires: php-composer(yoast/phpunit-polyfills) < %{polyfills_max_ver}
+BuildRequires: php-composer(yoast/phpunit-polyfills) >= %{polyfills_min_ver}
%endif
## phpcompatinfo (computed from version 2.0.1)
BuildRequires: php-pcre
@@ -135,18 +141,23 @@ cp -rp src %{buildroot}%{phpdir}/Consolidation/Log
%check
%if %{with_tests}
: Create tests bootstrap
-cat <<'BOOTSTRAP' | tee bootstrap.php
+mkdir vendor
+cat <<'BOOTSTRAP' | tee vendor/autoload.php
<?php
require '%{buildroot}%{phpdir}/Consolidation/Log/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('Consolidation\\TestUtils\\', __DIR__.'/tests/src');
+\Fedora\Autoloader\Autoload::addPsr4('Consolidation\\TestUtils\\', dirname(__DIR__).'/tests/src');
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Yoast/PHPUnitPolyfills/autoload.php',
+]);
BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which %{phpunit_exec})
-for PHP_EXEC in "" php72 php73 php74; do
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ $PHP_EXEC $PHPUNIT --verbose --no-coverage \
|| RETURN_CODE=1
fi
done
@@ -166,6 +177,10 @@ exit $RETURN_CODE
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+- switch to phpunit9 with yoast/phpunit-polyfills
+
* Mon Sep 07 2020 Shawn Iwinski <shawn@iwin.ski> - 2.0.1-1
- Update to 2.0.1 (RHBZ #1850810)