summaryrefslogtreecommitdiffstats
path: root/php-consolidation-annotated-command.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-consolidation-annotated-command.spec')
-rw-r--r--php-consolidation-annotated-command.spec38
1 files changed, 22 insertions, 16 deletions
diff --git a/php-consolidation-annotated-command.spec b/php-consolidation-annotated-command.spec
index 55e1d8c..eea55ed 100644
--- a/php-consolidation-annotated-command.spec
+++ b/php-consolidation-annotated-command.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-consolidation-annotated-command
#
-# Copyright (c) 2016-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,18 +10,18 @@
# Please preserve changelog entries
#
-%global github_owner consolidation-org
+%global github_owner consolidation
%global github_name annotated-command
-%global github_version 2.8.3
-%global github_commit 8f8f5da2ca06fbd3a85f7d551c49f844b7c59437
+%global github_version 2.12.0
+%global github_commit 512a2e54c98f3af377589de76c43b24652bcb789
%global composer_vendor consolidation
%global composer_project annotated-command
-# "php": ">=5.4.0"
-%global php_min_ver 5.4.0
-# "consolidation/output-formatters": "^3.1.12"
-%global consolidation_output_formatters_min_ver 3.1.12
+# "php": ">=5.4.5"
+%global php_min_ver 5.4.5
+# "consolidation/output-formatters": "^3.4"
+%global consolidation_output_formatters_min_ver 3.4
%global consolidation_output_formatters_max_ver 4
# "psr/log": "^1"
# NOTE: Min version not 1.0 because autoloader required
@@ -47,10 +47,13 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Initialize Symfony Console commands from annotated command class methods
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests
+# Run php-consolidation-annotated-command-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
@@ -74,7 +77,7 @@ BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/event-dispatcher) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/finder) < %{symfony_max_ver}
%endif
-## phpcompatinfo (computed from version 2.8.3)
+## phpcompatinfo (computed from version 2.12.0)
BuildRequires: php-dom
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -100,7 +103,7 @@ Requires: php-composer(symfony/console) < %{symfony_max_ver}
Requires: php-composer(symfony/event-dispatcher) < %{symfony_max_ver}
Requires: php-composer(symfony/finder) < %{symfony_max_ver}
%endif
-# phpcompatinfo (computed from version 2.8.3)
+# phpcompatinfo (computed from version 2.12.0)
Requires: php-dom
Requires: php-pcre
Requires: php-reflection
@@ -156,8 +159,8 @@ AUTOLOAD
%install
-mkdir -p %{buildroot}%{phpdir}/Consolidation/AnnotatedCommand
-cp -rp src/* %{buildroot}%{phpdir}/Consolidation/AnnotatedCommand/
+mkdir -p %{buildroot}%{phpdir}/Consolidation
+cp -rp src %{buildroot}%{phpdir}/Consolidation/AnnotatedCommand
%check
@@ -171,7 +174,7 @@ BOOTSTRAP
: Skip test known to fail
sed 's/function testInteractAndValidate/function SKIP_testInteractAndValidate/' \
- -i tests/testAnnotatedCommandFactory.php
+ -i tests/AnnotatedCommandFactoryTest.php
: Update tests if symfony/var-dumper is installed
if \
@@ -184,7 +187,7 @@ fi
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php55 php56 php70} php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -206,6 +209,9 @@ exit $RETURN_CODE
%changelog
+* Sat Jun 01 2019 Shawn Iwinski <shawn@iwin.ski> - 2.12.0-1
+- Update to 2.12.0 (RHBZ #1582689)
+
* Fri Mar 30 2018 Shawn Iwinski <shawn@iwin.ski> - 2.8.3-1
- Update to 2.8.3 (RHBZ #1492447)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8