summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-01 08:09:06 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-01 08:09:06 +0100
commit7535406c914e06c0338253976e795de5738521e9 (patch)
tree2c0f85dc29902e98c7a6c04ed6b066de863b5564
parentad10502cf623a6774f563253d695807a01680214 (diff)
php-consolidation-annotated-command: 2.4.4 (backported from Fedora)
-rw-r--r--composer.json2
-rw-r--r--php-consolidation-annotated-command.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 3c287ad..693b071 100644
--- a/composer.json
+++ b/composer.json
@@ -28,7 +28,7 @@
"phpdocumentor/reflection-docblock": "^2.0|^3.0.2"
},
"require-dev": {
- "phpunit/phpunit": "4.*",
+ "phpunit/phpunit": "^4.8",
"satooshi/php-coveralls": "^1.0",
"squizlabs/php_codesniffer": "^2.7"
},
diff --git a/php-consolidation-annotated-command.spec b/php-consolidation-annotated-command.spec
index 064ec2d..4345fe5 100644
--- a/php-consolidation-annotated-command.spec
+++ b/php-consolidation-annotated-command.spec
@@ -12,8 +12,8 @@
%global github_owner consolidation-org
%global github_name annotated-command
-%global github_version 2.2.2
-%global github_commit 1f1d92807f72901e049e9df048b412c3bc3652c9
+%global github_version 2.4.4
+%global github_commit ccff73e46582a885ce4bb2c57bbd8ba4415dbd24
%global composer_vendor consolidation
%global composer_project annotated-command
@@ -72,7 +72,7 @@ BuildRequires: php-composer(symfony/event-dispatcher) < %{symfony_max_
BuildRequires: php-composer(symfony/event-dispatcher) >= %{symfony_min_ver}
BuildRequires: php-composer(symfony/finder) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/finder) >= %{symfony_min_ver}
-## phpcompatinfo (computed from version 2.2.2)
+## phpcompatinfo (computed from version 2.4.4)
BuildRequires: php-dom
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -95,7 +95,7 @@ Requires: php-composer(symfony/event-dispatcher) < %{symfony_max_
Requires: php-composer(symfony/event-dispatcher) >= %{symfony_min_ver}
Requires: php-composer(symfony/finder) < %{symfony_max_ver}
Requires: php-composer(symfony/finder) >= %{symfony_min_ver}
-# phpcompatinfo (computed from version 2.2.2)
+# phpcompatinfo (computed from version 2.4.4)
Requires: php-dom
Requires: php-pcre
Requires: php-reflection
@@ -164,7 +164,7 @@ sed 's/function testInteractAndValidate/function SKIP_testInteractAndValidate/'
: Upstream tests with SCLs if available
SCL_RETURN_CODE=0
-for SCL in php56 php70 php71; do
+for SCL in %{?rhel:php55} php56 php70 php71; do
if which $SCL; then
$SCL %{_bindir}/phpunit --bootstrap bootstrap.php || SCL_RETURN_CODE=1
fi
@@ -189,6 +189,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Feb 28 2017 Shawn Iwinski <shawn@iwin.ski> - 2.4.4-1
+- Update to 2.4.4 (RHBZ #1415385)
+
* Sun Jan 15 2017 Shawn Iwinski <shawn@iwin.ski> - 2.2.2-1
- Update to 2.2.2 (RHBZ #1395001)
- Use php-composer(fedora/autoloader)