summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-25 14:19:25 +0100
committerRemi Collet <remi@php.net>2022-02-25 14:19:25 +0100
commitbb9521dc36ea33d13281ca3e47d2bdfc08d90ad3 (patch)
tree7154f69bffdf15e785f4315e699c346368fe1b75
parent7de03695d9fc6a706ed91e16b68a7a95487a3831 (diff)
update to 3.0.2
rename to php-composer-xdebug-handler3 install in /usr/share/php/Composer/XdebugHandler3 raise dependency on PHP 7.2.5
-rw-r--r--composer.json8
-rw-r--r--php-composer-xdebug-handler3.spec22
2 files changed, 18 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index ccd33ef..a2cfd6d 100644
--- a/composer.json
+++ b/composer.json
@@ -18,12 +18,12 @@
"issues": "https://github.com/composer/xdebug-handler/issues"
},
"require": {
- "php": "^5.3.2 || ^7.0 || ^8.0",
+ "php": "^7.2.5 || ^8.0",
"psr/log": "^1 || ^2 || ^3",
"composer/pcre": "^1"
},
"require-dev": {
- "symfony/phpunit-bridge": "^4.2 || ^5.0 || ^6.0",
+ "symfony/phpunit-bridge": "^6.0",
"phpstan/phpstan": "^1.0",
"phpstan/phpstan-strict-rules": "^1.1"
},
@@ -38,7 +38,7 @@
}
},
"scripts": {
- "test": "vendor/bin/simple-phpunit",
- "phpstan": "vendor/bin/phpstan analyse"
+ "test": "@php vendor/bin/simple-phpunit",
+ "phpstan": "@php vendor/bin/phpstan analyse"
}
}
diff --git a/php-composer-xdebug-handler3.spec b/php-composer-xdebug-handler3.spec
index 666f8e4..74e2947 100644
--- a/php-composer-xdebug-handler3.spec
+++ b/php-composer-xdebug-handler3.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-composer-xdebug-handler2
+# remirepo/fedora spec file for php-composer-xdebug-handler3
#
# Copyright (c) 2018-2022 Remi Collet
# License: CC-BY-SA
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 9e36aeed4616366d2b690bdce11f71e9178c579a
+%global gh_commit b11b961ef6b11e380e81a20b27c8cad54eeefe61
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -18,12 +18,12 @@
%global ns_vendor Composer
%global ns_project XdebugHandler
-%global major 2
+%global major 3
%global php_home %{_datadir}/php
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 2.0.5
+Version: 3.0.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Restarts a process without Xdebug, version %{major}
@@ -36,13 +36,13 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
# For tests
-BuildRequires: php(language) >= 5.3.2
+BuildRequires: php(language) >= 7.2.5
BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "symfony/phpunit-bridge": "^4.2 || ^5.0 || ^6.0",
+# "symfony/phpunit-bridge": "^6.0",
# "phpstan/phpstan": "^1.0",
# "phpstan/phpstan-strict-rules": "^1.1"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -59,10 +59,10 @@ BuildRequires: phpunit9
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": "^5.3.2 || ^7.0 || ^8.0",
+# "php": "^7.2.5 || ^8.0",
# "psr/log": "^1 || ^2 || ^3"
# "composer/pcre": "^1"
-Requires: php(language) >= 5.3.2
+Requires: php(language) >= 7.2.5
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 4)
Requires: (php-composer(composer/pcre) >= 1.0 with php-composer(composer/pcre) < 2)
@@ -150,6 +150,12 @@ exit $ret
%changelog
+* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+- rename to php-composer-xdebug-handler3
+- install in /usr/share/php/Composer/XdebugHandler3
+- raise dependency on PHP 7.2.5
+
* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 2.0.5-1
- update to 2.0.5