summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-composer-xdebug-handler.spec22
2 files changed, 17 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index ea40a2f..7df9ea6 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,8 @@
"psr/log": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8"
+ "symfony/phpunit-bridge": "^4.2 || ^5",
+ "phpstan/phpstan": "^0.12.55"
},
"autoload": {
"psr-4": {
@@ -35,6 +36,7 @@
}
},
"scripts": {
- "test": "phpunit"
+ "test": "SYMFONY_PHPUNIT_REMOVE_RETURN_TYPEHINT=1 vendor/bin/simple-phpunit",
+ "phpstan": "vendor/bin/phpstan analyse"
}
}
diff --git a/php-composer-xdebug-handler.spec b/php-composer-xdebug-handler.spec
index ba2f801..2660fea 100644
--- a/php-composer-xdebug-handler.spec
+++ b/php-composer-xdebug-handler.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-composer-xdebug-handler
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit f28d44c286812c714741478d968104c5e604a1d4
+%global gh_commit f27e06cd9675801df441b3656569b328e04aa37c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -16,10 +16,10 @@
%global ns_project XdebugHandler
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.5
+Version: 1.4.6
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Restarts a process without Xdebug
@@ -30,7 +30,7 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 5.3.2
BuildRequires: php-reflection
@@ -39,7 +39,8 @@ BuildRequires: php-pcre
BuildRequires: php-posix
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8"
+# "symfony/phpunit-bridge": "^4.2 || ^5",
+# "phpstan/phpstan": "^0.12.55"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
BuildRequires: phpunit8
@@ -49,9 +50,9 @@ BuildRequires: php-PsrLog
BuildRequires: php-phpunit-PHPUnit >= 4.8.35
%global phpunit %{_bindir}/phpunit
%endif
+%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
-%endif
# From composer.json, "require": {
# "php": "^5.3.2 || ^7.0 || ^8.0",
@@ -114,9 +115,9 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.ph
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', dirname(__DIR__).'/tests');
EOF
-%if %{with_tests}
+%if %{with tests}
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit8} --verbose|| ret=1
@@ -138,6 +139,9 @@ exit $ret
%changelog
+* Fri Mar 26 2021 Remi Collet <remi@remirepo.net> - 1.4.6-1
+- update to 1.4.6
+
* Fri Nov 13 2020 Remi Collet <remi@remirepo.net> - 1.4.5-1
- update to 1.4.5