summaryrefslogtreecommitdiffstats
path: root/php-composer-xdebug-handler.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-26 18:01:31 +0200
committerRemi Collet <remi@remirepo.net>2018-03-26 18:01:31 +0200
commit88d429c6fe0220db8941e2008896c2c6113045d8 (patch)
treee61f70687a18d01fbad5f1cf525f59749201adad /php-composer-xdebug-handler.spec
new package
Diffstat (limited to 'php-composer-xdebug-handler.spec')
-rw-r--r--php-composer-xdebug-handler.spec142
1 files changed, 142 insertions, 0 deletions
diff --git a/php-composer-xdebug-handler.spec b/php-composer-xdebug-handler.spec
new file mode 100644
index 0000000..48925ce
--- /dev/null
+++ b/php-composer-xdebug-handler.spec
@@ -0,0 +1,142 @@
+# remirepo/fedora spec file for php-composer-xdebug-handler
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 1852e549ad0d6f2910f89c27fec833dda1b25b4a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_date 20150717
+%global gh_owner composer
+%global gh_project xdebug-handler
+
+%global ns_vendor Composer
+%global ns_project XdebugHandler
+
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.0.0
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Summary: Restarts a process without xdebug
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.3.2
+BuildRequires: php-reflection
+BuildRequires: php-ctype
+BuildRequires: php-pcre
+BuildRequires: php-posix
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
+BuildRequires: phpunit6 >= 6.5
+%global phpunit %{_bindir}/phpunit6
+%else
+BuildRequires: php-PsrLog
+BuildRequires: php-phpunit-PHPUnit >= 5.7
+%global phpunit %{_bindir}/phpunit
+%endif
+# Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require": {
+# "php": "^5.3.2 || ^7.0",
+# "psr/log": "^1.0"
+Requires: php(language) >= 5.3.2
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
+%else
+Requires: php-PsrLog
+%endif
+# From phpcompatinfo report for version 1.0.0
+Requires: php-reflection
+Requires: php-ctype
+Requires: php-pcre
+Requires: php-posix
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Restart a CLI process without loading the xdebug extension.
+
+Originally written as part of composer/composer, now extracted
+and made available as a stand-alone library.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+cat << 'EOF' | tee src/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
+\Fedora\Autoloader\Dependencies::required(array(
+ '%{_datadir}/php/Psr/Log/autoload.php',
+));
+EOF
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%check
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', dirname(__DIR__).'/tests');
+EOF
+
+%if %{with_tests}
+ret=0
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose|| ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%dir %{_datadir}/php/%{ns_vendor}
+ %{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Mon Mar 26 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0