summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-composer-spdx-licenses-rpm.patch20
-rw-r--r--php-composer-spdx-licenses.spec9
2 files changed, 24 insertions, 5 deletions
diff --git a/php-composer-spdx-licenses-rpm.patch b/php-composer-spdx-licenses-rpm.patch
index 08bc3f6..3d8227e 100644
--- a/php-composer-spdx-licenses-rpm.patch
+++ b/php-composer-spdx-licenses-rpm.patch
@@ -1,6 +1,6 @@
diff -up src/SpdxLicenses.php.rpm src/SpdxLicenses.php
---- src/SpdxLicenses.php.rpm 2015-07-17 07:41:29.007308656 +0200
-+++ src/SpdxLicenses.php 2015-07-17 07:43:40.425973108 +0200
+--- src/SpdxLicenses.php.rpm 2015-09-08 09:17:14.000000000 +0200
++++ src/SpdxLicenses.php 2015-09-08 09:19:33.416111340 +0200
@@ -178,7 +178,7 @@ class SpdxLicenses
*/
public static function getResourcesDir()
@@ -10,3 +10,19 @@ diff -up src/SpdxLicenses.php.rpm src/SpdxLicenses.php
}
private function loadLicenses()
+diff -up tests/SpdxLicensesTest.php.rpm tests/SpdxLicensesTest.php
+--- tests/SpdxLicensesTest.php.rpm 2015-09-08 09:20:20.453342020 +0200
++++ tests/SpdxLicensesTest.php 2015-09-08 09:21:51.442788249 +0200
+@@ -64,12 +64,6 @@ class SpdxLicensesTest extends \PHPUnit_
+ is_dir($dir),
+ 'Expected resources directory to exist.'
+ );
+-
+- $this->assertEquals(
+- realpath($dir),
+- realpath(__DIR__ . '/../res'),
+- 'Expected resources directory to be "res" (relative to project root).'
+- );
+ }
+
+ /**
diff --git a/php-composer-spdx-licenses.spec b/php-composer-spdx-licenses.spec
index 56bcb0b..c2eafa2 100644
--- a/php-composer-spdx-licenses.spec
+++ b/php-composer-spdx-licenses.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2f17228c1b98283b779698cefa917f7f4fd0b0d4
+%global gh_commit 324b3530ac3e6277ff4bedf82a34fbf35836eb8d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -15,8 +15,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-spdx-licenses
-Version: 1.1.0
-Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Version: 1.1.1
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: SPDX licenses list and validation library
Group: Development/Libraries
@@ -122,6 +122,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Sep 8 2015 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- version 1.1.1
+
* Mon Jul 20 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-2
- fix permissions