summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-composer-semver.spec26
2 files changed, 20 insertions, 8 deletions
diff --git a/makesrc.sh b/makesrc.sh
index bde65fc..c047df5 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -15,7 +15,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
+cp composer.json ../composer.json
popd
echo "Archiving..."
diff --git a/php-composer-semver.spec b/php-composer-semver.spec
index d7b323b..8bccf93 100644
--- a/php-composer-semver.spec
+++ b/php-composer-semver.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 03c9de5aa25e7672c4ad251eeaba0c47a06c8b98
+%global gh_commit c7cb9a2095a074d131b65a8a0cd294479d785573
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-semver
-Version: 1.4.1
+Version: 1.4.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Semver library that offers utilities, version constraint parsing and validation
@@ -87,15 +87,24 @@ cp -pr src %{buildroot}%{php_home}/Composer/Semver
%check
%if %{with_tests}
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/Composer/Semver/autoload.php
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/Composer/Semver/autoload.php
+ run=1
+fi
+if [ $run -eq 0 ]; then
%{_bindir}/phpunit \
--bootstrap %{buildroot}%{php_home}/Composer/Semver/autoload.php \
--verbose
-
-if which php70; then
- php70 %{_bindir}/phpunit \
- --bootstrap %{buildroot}%{php_home}/Composer/Semver/autoload.php \
- --verbose
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -116,6 +125,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Sep 1 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
+- update to 1.4.2
+
* Thu Jun 2 2016 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
- update to 1.4.1