summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-composer-semver.spec46
2 files changed, 32 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index b0400cd..0d9559f 100644
--- a/composer.json
+++ b/composer.json
@@ -31,11 +31,10 @@
"issues": "https://github.com/composer/semver/issues"
},
"require": {
- "php": "^5.3.2 || ^7.0"
+ "php": "^5.3.2 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.5 || ^5.0.5",
- "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
+ "phpunit/phpunit": "^4.5 || ^5.0.5"
},
"autoload": {
"psr-4": {
diff --git a/php-composer-semver.spec b/php-composer-semver.spec
index 61499aa..8712372 100644
--- a/php-composer-semver.spec
+++ b/php-composer-semver.spec
@@ -1,23 +1,25 @@
# remirepo/fedora spec file for php-composer-semver
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 46d9139568ccb8d9e7cdd4539cab7347568a5e2e
+
+%bcond_without tests
+
+%global gh_commit 647490bbcaf7fc4891c58f47b825eb99d19c377a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
%global gh_project semver
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
Name: php-composer-semver
-Version: 1.5.0
+Version: 1.7.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
-Summary: Semver library that offers utilities, version constraint parsing and validation
+Summary: Semver library version 1
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -27,22 +29,20 @@ Source1: makesrc.sh
Source2: %{name}-autoload.php
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 5.3.2
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.5 || ^5.0.5",
-# "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
+# "phpunit/phpunit": "^4.5 || ^5.0.5"
BuildRequires: php-composer(phpunit/phpunit) >= 4.5
-BuildRequires: php-composer(phpunit/phpunit-mock-objects) >= 2.3
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": "^5.3.2 || ^7.0",
+# "php": "^5.3.2 || ^7.0 || ^8.0",
Requires: php(language) >= 5.3.2
# From phpcompatinfo report for version 1.5.0
Requires: php-pcre
@@ -54,14 +54,13 @@ Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
%description
-Semver library that offers utilities, version constraint parsing
-and validation.
+Semver library version 1 that offers utilities, version constraint
+parsing and validation.
Originally written as part of composer/composer, now extracted and
made available as a stand-alone library.
-To use this library, you just have to add, in your project:
- require_once '%{_datadir}/php/Composer/Semver/autoload.php';
+Autoloader: %{_datadir}/php/Composer/Semver/autoload.php
%prep
@@ -81,9 +80,9 @@ cp -pr src %{buildroot}%{php_home}/Composer/Semver
%check
-%if %{with_tests}
+%if %{with tests}
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--bootstrap %{buildroot}%{php_home}/Composer/Semver/autoload.php \
@@ -107,6 +106,21 @@ exit $ret
%changelog
+* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 1.7.1-1
+- update to 1.7.1
+
+* Wed Sep 9 2020 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0
+
+* Wed Sep 9 2020 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+
+* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- update to 1.5.1
+
* Wed Mar 20 2019 Remi Collet <remi@remirepo.net> - 1.5.0-1
- update to 1.5.0