summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-31 16:02:13 +0200
committerRemi Collet <remi@php.net>2022-03-31 16:02:13 +0200
commit89f3064041267f12d441bf4aa3605c6acef6a1bc (patch)
treef048c72ccd6d1986e04d5eb6e52b1f0cd0b20e28
dump v1
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json46
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-composer-pcre3.spec127
5 files changed, 213 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e49047c
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,46 @@
+{
+ "name": "composer/pcre",
+ "description": "PCRE wrapping library that offers type-safe preg_* replacements.",
+ "type": "library",
+ "license": "MIT",
+ "keywords": [
+ "pcre",
+ "regex",
+ "preg",
+ "regular expression"
+ ],
+ "authors": [
+ {
+ "name": "Jordi Boggiano",
+ "email": "j.boggiano@seld.be",
+ "homepage": "http://seld.be"
+ }
+ ],
+ "require": {
+ "php": "^5.3.2 || ^7.0 || ^8.0"
+ },
+ "require-dev": {
+ "symfony/phpunit-bridge": "^4.2 || ^5",
+ "phpstan/phpstan": "^1.3",
+ "phpstan/phpstan-strict-rules": "^1.1"
+ },
+ "autoload": {
+ "psr-4": {
+ "Composer\\Pcre\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Composer\\Pcre\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-main": "1.x-dev"
+ }
+ },
+ "scripts": {
+ "test": "SYMFONY_PHPUNIT_REMOVE_RETURN_TYPEHINT=1 vendor/bin/simple-phpunit",
+ "phpstan": "phpstan analyse"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..dfd5c2a
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-composer-pcre3.spec b/php-composer-pcre3.spec
new file mode 100644
index 0000000..859b785
--- /dev/null
+++ b/php-composer-pcre3.spec
@@ -0,0 +1,127 @@
+# remirepo/fedora spec file for php-composer-pcre
+#
+# Copyright (c) 2021-2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+%global gh_commit 67a32d7d6f9f560b726ab25a061b38ff3a80c560
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_date 20150717
+%global gh_owner composer
+%global gh_project pcre
+%global ns_vendor Composer
+%global ns_project Pcre
+%global php_home %{_datadir}/php
+%global major %nil
+
+Name: php-%{gh_owner}-%{gh_project}%{major}
+Version: 1.0.1
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Summary: PCRE wrapping library version 1
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with tests}
+# For tests
+BuildRequires: php(language) >= 5.3.2
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "symfony/phpunit-bridge": "^4.2 || ^5",
+# "phpstan/phpstan": "^1.3",
+# "phpstan/phpstan-strict-rules": "^1.1"
+%global phpunit /usr/bin/phpunit9
+BuildRequires: %{phpunit}
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+%endif
+
+# From composer.json, "require": {
+# "php": "^5.3.2 || ^7.0 || ^8.0"
+Requires: php(language) >= 5.3.2
+# From phpcompatinfo report for version 1.0.0
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+PCRE wrapping library that offers type-safe preg_* replacements.
+
+This library gives you a way to ensure preg_* functions do not fail silently,
+returning unexpected nulls that may not be handled.
+
+It also makes it easier ot work with static analysis tools like PHPStan or
+Psalm as it simplifies and reduces the possible return values from all the
+preg_* functions which are quite packed with edge cases.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate classmap autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}/
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once "%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php";
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}', dirname(__DIR__).'/tests');
+EOF
+
+ret=0
+for cmd in php php74 php80 php81; do
+ if which $cmd; then
+ $cmd %{phpunit} \
+ --verbose || ret=1
+ fi
+done
+
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Sat Jan 22 2022 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+
+* Wed Dec 8 2021 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0