summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-25 14:40:50 +0200
committerRemi Collet <remi@php.net>2024-07-25 14:40:50 +0200
commit1023c83440a4b835d707685f5adb9884f6447b07 (patch)
treefd6c9d0505b7d9228ea4fe8fc98fd7b91fc7f915
parent9df79e5c7a7a33352c7ecbf7cc1ba9faa3def717 (diff)
update to 3.2.0
-rw-r--r--composer.json16
-rw-r--r--php-composer-pcre3.spec16
2 files changed, 21 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 40477ff..9e827a9 100644
--- a/composer.json
+++ b/composer.json
@@ -20,10 +20,13 @@
"php": "^7.4 || ^8.0"
},
"require-dev": {
- "symfony/phpunit-bridge": "^5",
- "phpstan/phpstan": "^1.3",
+ "phpunit/phpunit": "^8 || ^9",
+ "phpstan/phpstan": "^1.11.8",
"phpstan/phpstan-strict-rules": "^1.1"
},
+ "conflict": {
+ "phpstan/phpstan": "<1.11.8"
+ },
"autoload": {
"psr-4": {
"Composer\\Pcre\\": "src"
@@ -37,10 +40,15 @@
"extra": {
"branch-alias": {
"dev-main": "3.x-dev"
+ },
+ "phpstan": {
+ "includes": [
+ "extension.neon"
+ ]
}
},
"scripts": {
- "test": "vendor/bin/simple-phpunit",
- "phpstan": "phpstan analyse"
+ "test": "@php vendor/bin/phpunit",
+ "phpstan": "@php phpstan analyse"
}
}
diff --git a/php-composer-pcre3.spec b/php-composer-pcre3.spec
index 79ad845..8cfc2d6 100644
--- a/php-composer-pcre3.spec
+++ b/php-composer-pcre3.spec
@@ -9,9 +9,9 @@
%bcond_without tests
-%global gh_commit 04229f163664973f68f38f6f73d917799168ef24
+%global gh_commit ea4ab6f9580a4fd221e0418f2c357cdd39102a90
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-05-27
+%global gh_date 2024-07-25
%global gh_owner composer
%global gh_project pcre
%global ns_vendor Composer
@@ -20,7 +20,7 @@
%global major 3
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 3.1.4
+Version: 3.2.0
Release: 1%{?dist}
Summary: PCRE wrapping library version %{major}
@@ -37,8 +37,8 @@ BuildRequires: php(language) >= 7.4
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "symfony/phpunit-bridge": "^5",
-# "phpstan/phpstan": "^1.3",
+# "phpunit/phpunit": "^8 || ^9",
+# "phpstan/phpstan": "^1.11.8",
# "phpstan/phpstan-strict-rules": "^1.1"
%global phpunit /usr/bin/phpunit9
BuildRequires: %{phpunit}
@@ -96,7 +96,7 @@ require_once "%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoloa
EOF
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php81 php82 php83 php84; do
if which $cmd; then
$cmd %{phpunit} \
--verbose || ret=1
@@ -111,7 +111,6 @@ exit $ret
%files
# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md
@@ -120,6 +119,9 @@ exit $ret
%changelog
+* Thu Jul 25 2024 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+
* Tue May 28 2024 Remi Collet <remi@remirepo.net> - 3.1.4-1
- update to 3.1.4