summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json47
-rwxr-xr-xmakesrc.sh31
-rw-r--r--php-composer-metadata-minifier.spec113
5 files changed, 204 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..d70a9be
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,47 @@
+{
+ "name": "composer/metadata-minifier",
+ "description": "Small utility library that handles metadata minification and expansion.",
+ "type": "library",
+ "license": "MIT",
+ "keywords": [
+ "compression",
+ "composer"
+ ],
+ "authors": [
+ {
+ "name": "Jordi Boggiano",
+ "email": "j.boggiano@seld.be",
+ "homepage": "http://seld.be"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/composer/metadata-minifier/issues"
+ },
+ "require": {
+ "php": "^5.3.2 || ^7.0 || ^8.0"
+ },
+ "require-dev": {
+ "symfony/phpunit-bridge": "^4.2 || ^5",
+ "phpstan/phpstan": "^0.12.55",
+ "composer/composer": "^2"
+ },
+ "autoload": {
+ "psr-4": {
+ "Composer\\MetadataMinifier\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Composer\\Test\\MetadataMinifier\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-main": "1.x-dev"
+ }
+ },
+ "scripts": {
+ "test": "SYMFONY_PHPUNIT_REMOVE_RETURN_TYPEHINT=1 vendor/bin/simple-phpunit",
+ "phpstan": "vendor/bin/phpstan analyse"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..b580388
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,31 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
+ echo skip $NAME-$VERSION-$SHORT.tgz
+else
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+ echo "Cloning..."
+ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+ echo "Getting commit..."
+ pushd $PROJECT-$COMMIT
+ git checkout $COMMIT | exit 1
+ cp composer.json ../composer.json
+ popd
+
+ echo "Archiving..."
+ tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+ echo "Cleaning..."
+ rm -rf $PROJECT-$COMMIT
+
+ echo "Done."
+fi
diff --git a/php-composer-metadata-minifier.spec b/php-composer-metadata-minifier.spec
new file mode 100644
index 0000000..a00cb58
--- /dev/null
+++ b/php-composer-metadata-minifier.spec
@@ -0,0 +1,113 @@
+# remirepo/fedora spec file for php-composer-metadata-minifier
+#
+# Copyright (c) 2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%bcond_without tests
+
+%global gh_commit c549d23829536f0d0e984aaabbf02af91f443207
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_date 20150717
+%global gh_owner composer
+%global gh_project metadata-minifier
+%global php_home %{_datadir}/php
+%global ns_vendor Composer
+%global ns_project MetadataMinifier
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.0.0
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Summary: Library that handles metadata minification and expansion
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with tests}
+# For tests
+BuildRequires: php(language) >= 5.3.2
+# From composer.json, "require-dev": {
+# "symfony/phpunit-bridge": "^4.2 || ^5",
+# "phpstan/phpstan": "^0.12.55",
+# "composer/composer": "^2"
+BuildRequires: composer >= 2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json, "require": {
+# "php": "^5.3.2 || ^7.0 || ^8.0",
+Requires: php(language) >= 5.3.2
+# From phpcompatinfo report for version 1.0
+# nothing
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Small utility library that handles metadata minification and expansion.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate classmap autoloader
+phpab -t fedora -o src/autoload.php src
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+# Composer autoloader (single build dependency)
+ln -s %{php_home}/%{ns_vendor}/autoload.php vendor/autoload.php
+
+# use auto_prepend_file as in composer autoloader
+ret=0
+for cmd in "php %{phpunit}" php73 php74 php80; do
+ if which $cmd; then
+ set $cmd
+ $1 -d memory_limit=1G \
+ -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
+ ${2:-%{_bindir}/phpunit9} \
+ --no-coverage \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Tue Apr 27 2021 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0