summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn Iwinski <shawn@iwin.ski>2017-10-08 18:23:54 -0700
committerRemi Collet <remi@remirepo.net>2017-10-09 07:04:03 +0200
commit9c0793efafa2c894aa5ea6a50b5345ed5c133405 (patch)
tree806a956608eadd78ce94a022d31992efe5e3319a
parentabdb0adb912be02a353b00fa57b3c4fd1f1a24c1 (diff)
Updated to 1.4.0 (RHBZ #1479799)
- Add composer.json file to repo
-rw-r--r--php-composer-installers.spec22
1 files changed, 13 insertions, 9 deletions
diff --git a/php-composer-installers.spec b/php-composer-installers.spec
index a5fcff9..bab5b9b 100644
--- a/php-composer-installers.spec
+++ b/php-composer-installers.spec
@@ -12,8 +12,8 @@
%global github_owner composer
%global github_name installers
-%global github_version 1.3.0
-%global github_commit 79ad876c7498c0bbfe7eed065b8651c93bfd6045
+%global github_version 1.4.0
+%global github_commit 9ce17fb70e9a38dd8acff0636a29f5cf4d575c1b
%global composer_vendor composer
%global composer_project installers
@@ -48,8 +48,8 @@ BuildRequires: php-composer(composer-plugin-api) >= %{composer_plugin_min_ver}
BuildRequires: php-composer(composer/composer) < %{composer_max_ver}
BuildRequires: php-composer(composer/composer) >= %{composer_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 1.3.0)
-BuildRequires: php(language) >= 5.4.0
+## phpcompatinfo (computed from version 1.4.0)
+BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pcre
BuildRequires: php-spl
## Autoloader
@@ -59,8 +59,8 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php-composer(composer-plugin-api) >= %{composer_plugin_min_ver}
Requires: php-composer(composer-plugin-api) < %{composer_plugin_max_ver}
-# phpcompatinfo (computed from version 1.3.0)
-Requires: php(language) >= 5.4.0
+# phpcompatinfo (computed from version 1.4.0)
+Requires: php(language) >= 5.3.0
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -123,9 +123,10 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php55} php56 php70 php71 php72; do
- if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71 php72; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -144,6 +145,9 @@ exit $RETURN_CODE
%changelog
+* Sun Oct 08 2017 Shawn Iwinski <shawn@iwin.ski> - 1.4.0-1
+- Updated to 1.4.0 (RHBZ #1479799)
+
* Sat Apr 29 2017 Shawn Iwinski <shawn@iwin.ski> - 1.3.0-1
- Updated to 1.3.0 (RHBZ #1444845)
- Added max version constraint to php-composer(composer/composer) dependency