summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-composer-ca-bundle-rpm.patch12
-rw-r--r--php-composer-ca-bundle.spec7
2 files changed, 17 insertions, 2 deletions
diff --git a/php-composer-ca-bundle-rpm.patch b/php-composer-ca-bundle-rpm.patch
index 54f656d..7ae8760 100644
--- a/php-composer-ca-bundle-rpm.patch
+++ b/php-composer-ca-bundle-rpm.patch
@@ -10,3 +10,15 @@ diff -up src/CaBundle.php.rpm src/CaBundle.php
// cURL does not understand 'phar://' paths
// see https://github.com/composer/ca-bundle/issues/10
+diff -up tests/CaBundleTest.php.rpm tests/CaBundleTest.php
+--- tests/CaBundleTest.php.rpm 2019-08-01 11:14:21.577672699 +0200
++++ tests/CaBundleTest.php 2019-08-01 11:14:31.322744408 +0200
+@@ -104,7 +104,7 @@ class CaBundleTest extends TestCase
+ public function testOpenBaseDir()
+ {
+ $oldValue = ini_get('open_basedir');
+- ini_set('open_basedir', realpath(__DIR__ . '/../'));
++ ini_set('open_basedir', '/usr/share/php:' . realpath(__DIR__ . '/../'));
+ $certFilePath = CaBundle::getSystemCaRootBundlePath();
+ $validResult = CaBundle::validateCaFile($certFilePath, null);
+ $this->assertTrue($validResult);
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index 596e047..d9f4c69 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 33810d865dd06a674130fceb729b2f279dc79e8c
+%global gh_commit ec2e24d4fa6a0d50d423794a56605ecec3401b85
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
@@ -14,7 +14,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-ca-bundle
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -142,6 +142,9 @@ exit $ret
%changelog
+* Thu Aug 1 2019 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+
* Thu Aug 1 2019 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1
- use PHPUnit 8