summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-composer-ca-bundle.spec12
2 files changed, 9 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index faeeb7b..22de0a8 100644
--- a/composer.json
+++ b/composer.json
@@ -29,7 +29,7 @@
"require-dev": {
"phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
"psr/log": "^1.0",
- "symfony/process": "^2.5 || ^3.0 || ^4.0"
+ "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0"
},
"autoload": {
"psr-4": {
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index c6f3677..d3aaf1f 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 10bb96592168a0f8e8f6dcde3532d9fa50b0b527
+%global gh_commit 62e8fc2dc550e5d6d8c9360c7721662670f58149
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
@@ -14,7 +14,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-ca-bundle
-Version: 1.2.4
+Version: 1.2.5
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -36,12 +36,12 @@ BuildRequires: php-cli
# From composer.json, "require": {
# "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
# "psr/log": "^1.0",
-# "symfony/process": "^2.5 || ^3.0 || ^4.0"
+# "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: phpunit6
%global phpunit %{_bindir}/phpunit8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
-BuildRequires: (php-composer(symfony/process) >= 2.5 with php-composer(symfony/process) < 5)
+BuildRequires: (php-composer(symfony/process) >= 2.5 with php-composer(symfony/process) < 6)
%else
BuildRequires: phpunit
%global phpunit %{_bindir}/phpunit
@@ -111,6 +111,7 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/Composer/CaBundle/autoload.php';
\Fedora\Autoloader\Dependencies::required(array(
array(
+ '%{php_home}/Symfony5/Component/Process/autoload.php',
'%{php_home}/Symfony4/Component/Process/autoload.php',
'%{php_home}/Symfony3/Component/Process/autoload.php',
'%{php_home}/Symfony/Component/Process/autoload.php',
@@ -142,6 +143,9 @@ exit $ret
%changelog
+* Thu Dec 12 2019 Remi Collet <remi@remirepo.net> - 1.2.5-1
+- update to 1.2.5
+
* Sun Sep 1 2019 Remi Collet <remi@remirepo.net> - 1.2.4-1
- update to 1.2.4 (no change)