summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-15 15:43:04 +0100
committerRemi Collet <remi@php.net>2024-03-15 15:43:04 +0100
commit0bbf6e68bb71cbc6b79214d1ea8690c6897e5f32 (patch)
treea43323f028843fe35f14420d0f75cc3f266f56e4
parentc539d736041f95a5fa174f49644d84429bb56703 (diff)
update to 1.5.0HEADmaster
raise dependency on PHP 7.2
-rw-r--r--composer.json8
-rw-r--r--php-composer-ca-bundle-rpm.patch4
-rw-r--r--php-composer-ca-bundle.spec18
3 files changed, 17 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index c85480a..a998783 100644
--- a/composer.json
+++ b/composer.json
@@ -24,13 +24,13 @@
"require": {
"ext-openssl": "*",
"ext-pcre": "*",
- "php": "^5.3.2 || ^7.0 || ^8.0"
+ "php": "^7.2 || ^8.0"
},
"require-dev": {
"symfony/phpunit-bridge": "^4.2 || ^5",
- "phpstan/phpstan": "^0.12.55",
+ "phpstan/phpstan": "^1.10",
"psr/log": "^1.0",
- "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0"
+ "symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
},
"autoload": {
"psr-4": {
@@ -48,7 +48,7 @@
}
},
"scripts": {
- "test": "SYMFONY_PHPUNIT_REMOVE_RETURN_TYPEHINT=1 vendor/bin/simple-phpunit",
+ "test": "vendor/bin/simple-phpunit",
"phpstan": "vendor/bin/phpstan analyse"
}
}
diff --git a/php-composer-ca-bundle-rpm.patch b/php-composer-ca-bundle-rpm.patch
index 9ff37d0..3dfdc65 100644
--- a/php-composer-ca-bundle-rpm.patch
+++ b/php-composer-ca-bundle-rpm.patch
@@ -13,8 +13,8 @@ diff -up ./src/CaBundle.php.rpm ./src/CaBundle.php
diff -up ./tests/CaBundleTest.php.rpm ./tests/CaBundleTest.php
--- ./tests/CaBundleTest.php.rpm 2021-01-12 13:55:35.957422992 +0100
+++ ./tests/CaBundleTest.php 2021-01-12 13:56:54.872069486 +0100
-@@ -124,7 +124,7 @@ class CaBundleTest extends TestCase
- public function testOpenBaseDir()
+@@ -97,7 +97,7 @@ class CaBundleTest extends TestCase
+ public function testOpenBaseDir(): void
{
$oldValue = ini_get('open_basedir') ?: '';
- ini_set('open_basedir', dirname(__DIR__));
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index a328422..5b39d42 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -9,14 +9,14 @@
%bcond_without tests
-%global gh_commit 18fc0ab083a48f85bfee31f3786537353b8a8403
+%global gh_commit 0c5ccfcfea312b5c5a190a21ac5cef93f74baf99
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
%global php_home %{_datadir}/php
Name: php-composer-ca-bundle
-Version: 1.4.2
+Version: 1.5.0
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -31,15 +31,15 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 5.3.2
+BuildRequires: php(language) >= 7.2
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-cli
# From composer.json, "require": {
# "symfony/phpunit-bridge": "^4.2 || ^5",
-# "phpstan/phpstan": "^0.12.55",
+# "phpstan/phpstan": "^1.10",
# "psr/log": "^1.0",
-# "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0"
+# "symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
BuildRequires: phpunit10
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -50,8 +50,8 @@ BuildRequires: %{_sysconfdir}/pki/tls/certs/ca-bundle.crt
# From composer.json, "require": {
# "ext-openssl": "*",
# "ext-pcre": "*",
-# "php": "^5.3.2 || ^7.0 || ^8.0"
-Requires: php(language) >= 5.3.2
+# "php": "^7.2 || ^8.0"
+Requires: php(language) >= 7.2
Requires: php-openssl
Requires: php-pcre
# From phpcompatinfo report for version 1.0.3
@@ -128,6 +128,10 @@ exit $ret
%changelog
+* Fri Mar 15 2024 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- raise dependency on PHP 7.2
+
* Thu Mar 14 2024 Remi Collet <remi@remirepo.net> - 1.4.2-1
- update to 1.4.2 (no change)