summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-10 10:43:06 +0200
committerRemi Collet <remi@remirepo.net>2017-09-10 10:43:06 +0200
commit5d958aae98302fb55787a4e49138ee5e7e692504 (patch)
tree6808fea659000f1865632c11e9668e62e0f0daa3
parent94d7b3578152c9da2a6bd3fb4e2fa10ee5883691 (diff)
backport
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json24
-rw-r--r--php-codeception-specify.spec1
4 files changed, 37 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..570a609
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,24 @@
+{
+ "name": "codeception/specify",
+ "description": "BDD code blocks for PHPUnit and Codeception",
+ "minimum-stability": "stable",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Michael Bodnarchuk",
+ "email": "davert.php@mailican.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.4.0",
+ "myclabs/deep-copy": "~1.1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.0"
+ },
+ "autoload": {
+ "psr-0": {
+ "Codeception\\": "src/"
+ }
+ }
+}
diff --git a/php-codeception-specify.spec b/php-codeception-specify.spec
index c2226f0..eddf1b9 100644
--- a/php-codeception-specify.spec
+++ b/php-codeception-specify.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-codeception-specify
#
# Fedora spec file for php-codeception-specify
#