summaryrefslogtreecommitdiffstats
path: root/php-clue-stream-filter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-clue-stream-filter.spec')
-rw-r--r--php-clue-stream-filter.spec17
1 files changed, 7 insertions, 10 deletions
diff --git a/php-clue-stream-filter.spec b/php-clue-stream-filter.spec
index ef0e52f..087ee5a 100644
--- a/php-clue-stream-filter.spec
+++ b/php-clue-stream-filter.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-clue-stream-filter
#
-# Copyright (c) 2017-2021 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2022 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner clue
%global github_name php-stream-filter
-%global github_version 1.5.0
-%global github_commit aeb7d8ea49c7963d3b581378955dbf5bc49aa320
+%global github_version 1.6.0
+%global github_commit d6169430c7731d8509da7aecd0af756a5747b78e
%global composer_vendor clue
%global composer_project stream-filter
@@ -44,14 +44,8 @@ BuildArch: noarch
%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
-# "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.36"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.3
-%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 4.8.35
-%endif
## phpcompatinfo (computed from version 1.5.0)
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -115,7 +109,7 @@ AUTOLOAD
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit" php73 php74 php80; do
+for CMDARG in "php %{phpunit}" php74 php80 php81; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} --verbose \
@@ -138,6 +132,9 @@ exit $RETURN_CODE
%changelog
+* Tue Feb 22 2022 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+
* Tue Nov 3 2020 Remi Collet <remi@remirepo.net> - 1.5.0-1
- update to 1.5.0
- switch to phpunit9