summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-clue-stream-filter.spec31
1 files changed, 16 insertions, 15 deletions
diff --git a/php-clue-stream-filter.spec b/php-clue-stream-filter.spec
index 62dc560..bb6247c 100644
--- a/php-clue-stream-filter.spec
+++ b/php-clue-stream-filter.spec
@@ -12,8 +12,8 @@
%global github_owner clue
%global github_name php-stream-filter
-%global github_version 1.3.0
-%global github_commit e3bf9415da163d9ad6701dccb407ed501ae69785
+%global github_version 1.4.0
+%global github_commit d80fdee9b3a7e0d16fc330a22f41f3ad0eeb09d0
%global composer_vendor clue
%global composer_project stream-filter
@@ -28,7 +28,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: A simple and modern approach to stream filtering in PHP
Group: Development/Libraries
@@ -42,7 +42,7 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 1.3.0)
+## phpcompatinfo (computed from version 1.4.0)
BuildRequires: php-reflection
BuildRequires: php-spl
BuildRequires: php-zlib
@@ -52,7 +52,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.3.0)
+# phpcompatinfo (computed from version 1.4.0)
Requires: php-reflection
Requires: php-spl
# Autoloader
@@ -96,19 +96,16 @@ cp -rp src %{buildroot}%{phpdir}/Clue/StreamFilter
%check
%if %{with_tests}
-BOOTSTRAP=%{buildroot}%{phpdir}/Clue/StreamFilter/autoload.php
-
: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php54 php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP || SCL_RETURN_CODE=1
+RETURN_CODE=0
+for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC %{_bindir}/phpunit --verbose \
+ --bootstrap %{buildroot}%{phpdir}/Clue/StreamFilter/autoload.php \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
@@ -124,6 +121,10 @@ exit $SCL_RETURN_CODE
%changelog
+* Thu Aug 31 2017 Shawn Iwinski <shawn@iwin.ski> - 1.4.0-1
+- Update to 1.4.0 (RHBZ #1482951)
+- Merge default and SCL tests (normailzed to what other specs use)
+
* Tue Jan 24 2017 Remi Collet <remi@remirepo.net> - 1.3.0-2
- backport for remi repo