summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-04 15:07:36 +0100
committerRemi Collet <remi@remirepo.net>2020-11-04 15:07:36 +0100
commitac3ce57419d60a5e753417a2a04b13c6e674cbfd (patch)
treeb6e318e07a6c064c693de5a2061d4006d7c156e7
new package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json31
l---------makesrc.sh1
-rwxr-xr-xphp-clue-http-proxy-react-get-source.sh74
-rw-r--r--php-clue-http-proxy-react.spec181
6 files changed, 299 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e34a14c
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,31 @@
+{
+ "name": "clue/http-proxy-react",
+ "description": "Async HTTP proxy connector, tunnel any TCP/IP-based protocol through an HTTP CONNECT proxy server, built on top of ReactPHP",
+ "keywords": ["HTTP", "CONNECT", "proxy", "ReactPHP", "async"],
+ "homepage": "https://github.com/clue/reactphp-http-proxy",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Christian Lück",
+ "email": "christian@clue.engineering"
+ }
+ ],
+ "autoload": {
+ "psr-4": { "Clue\\React\\HttpProxy\\": "src/" }
+ },
+ "autoload-dev": {
+ "psr-4": { "Clue\\Tests\\React\\HttpProxy\\": "tests/" }
+ },
+ "require": {
+ "php": ">=5.3",
+ "react/promise": " ^2.1 || ^1.2.1",
+ "react/socket": "^1.1",
+ "ringcentral/psr7": "^1.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8",
+ "react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3",
+ "react/http": "^1.0",
+ "clue/block-react": "^1.1"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..0ab2b48
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-clue-http-proxy-react-get-source.sh \ No newline at end of file
diff --git a/php-clue-http-proxy-react-get-source.sh b/php-clue-http-proxy-react-get-source.sh
new file mode 100755
index 0000000..8b02c4f
--- /dev/null
+++ b/php-clue-http-proxy-react-get-source.sh
@@ -0,0 +1,74 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+SPEC_DIR=`pwd`
+
+print "SPEC_DIR = $SPEC_DIR"
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json ${SPEC_DIR}/
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=${SPEC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-clue-http-proxy-react.spec b/php-clue-http-proxy-react.spec
new file mode 100644
index 0000000..30e5932
--- /dev/null
+++ b/php-clue-http-proxy-react.spec
@@ -0,0 +1,181 @@
+# remirepo/fedora spec file for php-clue-http-proxy-react
+#
+# Copyright (c) 2020 Remi Collet, Shawn Iwinski
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner clue
+%global github_name reactphp-http-proxy
+%global github_version 1.6.0
+%global github_commit 005e7d518a1e69fc8d321e3f719c9024d4d4200d
+
+%global composer_vendor clue
+%global composer_project http-proxy-react
+
+
+# Build using "--without tests" to disable tests
+%bcond_without tests
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: Async HTTP proxy connector
+
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests
+# Run php-clue-http-proxy-react-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with tests}
+BuildRequires: php(language) >= 5.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(react/promise) >= 2.1 with php-composer(react/promise) < 3)
+BuildRequires: (php-composer(react/socket) >= 1.1 with php-composer(react/socket) < 2)
+BuildRequires: (php-composer(ringcentral/psr7) >= 1.2 with php-composer(ringcentral/psr7) < 2)
+## composer.json
+# "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8",
+# "react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3",
+# "react/http": "^1.0",
+# "clue/block-react": "^1.1"
+# ignore react/http only used in examples
+BuildRequires: (php-composer(react/event-loop) >= 1.0 with php-composer(react/event-loop) < 2)
+BuildRequires: (php-composer(clue/block-react) >= 1.1 with php-composer(clue/block-react) < 2)
+%else
+BuildRequires: php-react-promise >= 2.1
+BuildRequires: php-react-socket >= 1.1
+BuildRequires: php-ringcentral-psr7 >= 1.2
+BuildRequires: php-react-event-loop >= 1.0
+BuildRequires: php-clue-block-react >= 1.1
+%endif
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-phpunit-PHPUnit >= 4.8
+%endif
+## phpcompatinfo (computed from version 1.6.0)
+BuildRequires: php-reflection
+BuildRequires: php-pcre
+BuildRequires: php-sockets
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# composer.json
+# "php": ">=5.3",
+# "react/promise": " ^2.1 || ^1.2.1",
+# "react/socket": "^1.1",
+# "ringcentral/psr7": "^1.2"
+Requires: php(language) >= 5.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(react/promise) >= 2.1 with php-composer(react/promise) < 3)
+Requires: (php-composer(react/socket) >= 1.1 with php-composer(react/socket) < 2)
+Requires: (php-composer(ringcentral/psr7) >= 1.2 with php-composer(ringcentral/psr7) < 2)
+%else
+Requires: php-react-promise >= 2.1
+Requires: php-react-socket >= 1.1
+Requires: php-ringcentral-psr7 >= 1.2
+%endif
+# phpcompatinfo (computed from version 1.6.0)
+Requires: php-reflection
+Requires: php-pcre
+Requires: php-sockets
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+Async HTTP proxy connector, tunnel any TCP/IP-based protocol through an
+HTTP CONNECT proxy server, built on top of ReactPHP.
+
+Autoloader: %{phpdir}/Clue/React/HttpProxy/autoload.php
+
+[1] http://reactphp.org/
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Clue\\React\\HttpProxy\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required(array(
+ '%{phpdir}/React/Promise/autoload.php',
+ '%{phpdir}/React/Socket/autoload.php',
+ '%{phpdir}/RingCentral/Psr7/autoload.php',
+));
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/Clue/React
+cp -rp src %{buildroot}%{phpdir}/Clue/React/HttpProxy
+
+
+%check
+%if %{with tests}
+: Mock Composer autoloader
+mkdir vendor
+cat <<'AUTOLOAD' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{phpdir}/Clue/React/HttpProxy/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Clue\\Tests\\React\\HttpProxy\\', dirname(__DIR__).'/tests');
+\Fedora\Autoloader\Dependencies::required(array(
+ '%{phpdir}/React/EventLoop/autoload.php',
+ '%{phpdir}/Clue/React/Block/autoload.php',
+));
+AUTOLOAD
+
+: Upstream tests
+RETURN_CODE=0
+for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit" php73 php74 php80; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit9} --verbose \
+ || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{phpdir}/Clue
+%dir %{phpdir}/Clue/React
+ %{phpdir}/Clue/React/HttpProxy
+
+
+%changelog
+* Wed Nov 4 2020 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- Initial package