summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--composer.json22
-rw-r--r--php-clue-block-react.spec4
3 files changed, 30 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f28bce8
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,22 @@
+{
+ "name": "clue/block-react",
+ "description": "Integrate async React PHP components into your blocking environment",
+ "keywords": ["Event Loop", "blocking", "synchronous", "Promise", "ReactPHP", "async"],
+ "homepage": "https://github.com/clue/php-block-react",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Christian Lück",
+ "email": "christian@lueck.tv"
+ }
+ ],
+ "autoload": {
+ "files": [ "src/functions.php" ]
+ },
+ "require": {
+ "php": ">=5.3",
+ "react/event-loop": "0.4.*|0.3.*",
+ "react/promise": "~2.1|~1.2",
+ "react/promise-timer": "~1.0"
+ }
+}
diff --git a/php-clue-block-react.spec b/php-clue-block-react.spec
index 81746eb..89be157 100644
--- a/php-clue-block-react.spec
+++ b/php-clue-block-react.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-clue-block-react, from:
#
# Fedora spec file for php-clue-block-react
#
@@ -149,6 +150,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Wed Jan 25 2017 Remi Collet <remi@remirepo.net> - 1.1.0-2
+- backport for remi repo
+
* Fri Jan 20 2017 Shawn Iwinski <shawn@iwin.ski> - 1.1.0-2
- Add missing BuildRequires and Requires
- Retrict react/promise dependency to one major version