summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-clue-block-react.spec24
2 files changed, 15 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 4545462..ddfc6c8 100644
--- a/composer.json
+++ b/composer.json
@@ -18,12 +18,12 @@
},
"require": {
"php": ">=5.3",
- "react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3.5",
- "react/promise": "^2.7 || ^1.2.1",
+ "react/event-loop": "^1.2",
+ "react/promise": "^3.0 || ^2.7 || ^1.2.1",
"react/promise-timer": "^1.5"
},
"require-dev": {
"phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.35",
- "react/http": "^1.0"
+ "react/http": "^1.4"
}
}
diff --git a/php-clue-block-react.spec b/php-clue-block-react.spec
index d47a970..f35aef2 100644
--- a/php-clue-block-react.spec
+++ b/php-clue-block-react.spec
@@ -12,20 +12,20 @@
%global github_owner clue
%global github_name reactphp-block
-%global github_version 1.4.0
-%global github_commit c8e7583ae55127b89d6915480ce295bac81c4f88
+%global github_version 1.5.0
+%global github_commit 718b0571a94aa693c6fffc72182e87257ac900f3
%global composer_vendor clue
%global composer_project block-react
# "php": ">=5.3"
%global php_min_ver 5.3
-# "react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3.5"
-%global react_event_loop_min_ver 0.3.5
+# "react/event-loop": "^1.2"
+%global react_event_loop_min_ver 1.2
%global react_event_loop_max_ver 2.0
-# "react/promise": "^2.7 || ^1.2.1"
+# "react/promise": "^3.0 || ^2.7 || ^1.2.1"
%global react_promise_min_ver 1.2.1
-%global react_promise_max_ver 3.0
+%global react_promise_max_ver 4
# "react/promise-timer": "^1.5"
%global react_promise_timer_min_ver 1.5
%global react_promise_timer_max_ver 2.0
@@ -55,14 +55,9 @@ BuildArch: noarch
%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
# "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.35"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.3
-%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 4.8.35
-%endif
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
BuildRequires: (php-composer(react/promise-timer) >= %{react_promise_timer_min_ver} with php-composer(react/promise-timer) < %{react_promise_timer_max_ver})
@@ -152,7 +147,7 @@ AUTOLOAD
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit" php73 php74 php80; do
+for CMDARG in "php %{phpunit}" php73 php74 php80 php81; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} --verbose \
@@ -176,6 +171,11 @@ exit $RETURN_CODE
%changelog
+* Thu Oct 21 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- raise dependency on react/event-loop 1.2
+- allow react/promise 3.0
+
* Tue Nov 3 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0
- switch to phpunit9