summaryrefslogtreecommitdiffstats
path: root/php-channel-symfony2.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:28:55 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:28:55 +0200
commitc76fc4f1f0a4b32a6284c5eebcad3fd1f6bd52dd (patch)
tree61ce8da48676ecb86b83c91656c627dbe210bc5a /php-channel-symfony2.spec
php-channel-symfony2: backport
Diffstat (limited to 'php-channel-symfony2.spec')
-rw-r--r--php-channel-symfony2.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/php-channel-symfony2.spec b/php-channel-symfony2.spec
new file mode 100644
index 0000000..6226092
--- /dev/null
+++ b/php-channel-symfony2.spec
@@ -0,0 +1,78 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_channel pear.symfony.com
+
+Name: php-channel-symfony2
+Version: 1.0
+Release: 3%{?dist}
+Summary: Adds %{pear_channel} channel to PEAR
+
+Group: Development/Libraries
+License: Public Domain
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/channel.xml
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-channel(%{pear_channel}) = %{version}
+
+%description
+This package adds the %{pear_channel} channel which allows PEAR packages from
+this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null || :
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{pear_channel} > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Sun Jun 09 2012 Remi Collet <RPMS@FamilleCollet.com> 1.0-3
+- rebuild for remi repository
+
+* Sat Jun 9 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-3
+- Changed license from MIT to Public Domain
+- Removed "BuildRequires: php-pear >= 1:1.4.9-1.2"
+- Removed cleaning buildroot from %%install section
+- Removed %%clean section
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-2
+- %%global instead of %%define
+- Removed BuildRoot
+- Removed %%defattr from %%files section
+- Minor syntax update in %%post section
+
+* Sat Apr 21 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-1
+- Initial package