summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-01 18:00:06 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-01 18:00:06 +0200
commit80d5e4223795651ce89b66be43188250b4134a9b (patch)
tree374a436700e14a3fa736b0b00117ee4192e992e6
php-channel-phpunit: import from rawhideHEADmaster
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-phpunit.spec101
3 files changed, 121 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..91bb678
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.phpunit.de</name>
+ <summary>PHPUnit PEAR Channel</summary>
+ <suggestedalias>phpunit</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.phpunit.de/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-phpunit.spec b/php-channel-phpunit.spec
new file mode 100644
index 0000000..adc913c
--- /dev/null
+++ b/php-channel-phpunit.spec
@@ -0,0 +1,101 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+Name: php-channel-phpunit
+# Use REST version
+Version: 1.3
+Release: 8%{?dist}
+Summary: Adds phpunit channel to PEAR
+
+Group: Development/Languages
+License: BSD
+URL: http://pear.phpunit.de
+Source0: http://pear.phpunit.de/channel.xml
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.4.9-1.2
+Requires: php-common >= 5.1.4
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-channel(pear.phpunit.de)
+
+%description
+This package adds the phpunit channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete pear.phpunit.de > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Wed Aug 11 2010 Remi Collet <Fedora@FamilleCollet.com> - 1.3-3
+- don't requires php but php-common (#577040)
+
+* Fri Dec 18 2009 Remi Collet <Fedora@FamilleCollet.com> - 1.3-2
+- missing Requires for post/postun
+
+* Fri Dec 18 2009 Remi Collet <Fedora@FamilleCollet.com> - 1.3-1
+- update for REST 1.3 and new URL (#542417)
+- rename pear.phpunit.de.xml to php-channel-phpunit.xml
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Fri Dec 29 2006 Christopher Stone <chris.stone@gmail.com> 1.0-2
+- Add virtual provides on channel name
+
+* Wed Dec 27 2006 Christopher Stone <chris.stone@gmail.com> 1.0-1
+- Initial Release