summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-05 08:55:28 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-05 08:55:28 +0100
commit96b5e02387ddd27279289865b9343498489f8ae1 (patch)
treed7a8ca7f522723e9645b9f032b31be562ab1bf54
php-channel-phpseclib: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-phpseclib.spec68
3 files changed, 88 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..3a957ae
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>phpseclib.sourceforge.net</name>
+ <summary>PHP Secure Communications Library PEAR channel</summary>
+ <suggestedalias>phpseclib</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://phpseclib.sourceforge.net//rest/</baseurl>
+ <baseurl type="REST1.1">http://phpseclib.sourceforge.net//rest/</baseurl>
+ <baseurl type="REST1.2">http://phpseclib.sourceforge.net//rest/</baseurl>
+ <baseurl type="REST1.3">http://phpseclib.sourceforge.net//rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-phpseclib.spec b/php-channel-phpseclib.spec
new file mode 100644
index 0000000..68f68c7
--- /dev/null
+++ b/php-channel-phpseclib.spec
@@ -0,0 +1,68 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global channelname phpseclib.sourceforge.net
+
+Name: php-channel-phpseclib
+Version: 1.3
+Release: 1%{?dist}
+Summary: Adds the phpseclib channel to PEAR
+
+Group: Development/Languages
+License: Public Domain
+URL: http://phpseclib.sourceforge.net/
+Source0: http://phpseclib.sourceforge.net/channel.xml
+
+BuildArch: noarch
+BuildRequires: php-pear
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-channel(%{channelname})
+
+%description
+This package adds the phpseclib channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+# fix line endings
+sed -i 's/\r$//' %{SOURCE0}
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+%{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+%{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+%{__pear} channel-delete %{channelname} > /dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Sat Jan 4 2014 Adam Williamson <awilliam@redhat.com> - 1.3-1
+- version using the rest version
+- drop use of tabs
+- drop unnecessary versioning of the buildrequires
+
+
+* Tue Dec 31 2013 Adam Williamson <awilliam@redhat.com> - 1.0-1
+- initial package
+