summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-06-05 07:21:51 +0200
committerRemi Collet <fedora@famillecollet.com>2013-06-05 07:21:51 +0200
commitd8303106d34cc2f1f4e3460363dcfc5a7629f259 (patch)
tree61f002a4d57b8f35950fa5ad4f091f86b6ce133a
php-channel-nrk: new package
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-nrk.spec75
3 files changed, 95 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..4031b5e
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.nrk.io</name>
+ <summary>nrk's PEAR channel</summary>
+ <suggestedalias>nrk</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.nrk.io/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.nrk.io/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.nrk.io/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.nrk.io/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-nrk.spec b/php-channel-nrk.spec
new file mode 100644
index 0000000..615d1e3
--- /dev/null
+++ b/php-channel-nrk.spec
@@ -0,0 +1,75 @@
+# spec file for php-channel-nrk
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the %changelog entries
+#
+%global channel pear.nrk.io
+Name: php-channel-nrk
+# REST version
+Version: 1.3
+Release: 1%{?dist}
+Summary: Adds pear.nrk.io channel to PEAR
+
+Group: Development/Languages
+License: Public Domain
+URL: http://%{channel}/
+Source0: http://%{channel}/channel.xml
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+BuildRequires: php-pear
+
+Requires: php-pear(PEAR)
+Requires(post): /usr/bin/pear
+Requires(postun): /usr/bin/pear
+
+Provides: php-channel(%{channel})
+
+%description
+This package adds the %{channel} channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{SOURCE0} %{buildroot}%{pear_xmldir}/%{channel}.xml
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{channel}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{channel}.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{channel} > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{channel}.xml
+
+
+%changelog
+* Wed Jun 05 2013 Remi Collet <remi@fedoraproject.org> - 1.3-1
+- Initial package