summaryrefslogtreecommitdiffstats
path: root/php-channel-horde.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:07:08 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:07:08 +0200
commit4f9a0d3f05aae82da8931757238efbe954d846c6 (patch)
tree4b82a40205d72339f94a2743396eafcd5bbaf7a3 /php-channel-horde.spec
repo reorg
Diffstat (limited to 'php-channel-horde.spec')
-rw-r--r--php-channel-horde.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/php-channel-horde.spec b/php-channel-horde.spec
new file mode 100644
index 0000000..f4eaa6f
--- /dev/null
+++ b/php-channel-horde.spec
@@ -0,0 +1,67 @@
+Name: php-channel-horde
+Version: 1.0
+Release: 1%{?dist}
+Summary: Adds pear.horde.org channel to PEAR
+
+Group: Development/Languages
+License: Public Domain
+URL: http://pear.horde.org/
+Source0: http://pear.horde.org/channel.xml
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.4.9-1.2
+
+Requires: php-pear(PEAR)
+Requires(post): /usr/bin/pear
+Requires(postun): /usr/bin/pear
+
+Provides: php-channel(pear.horde.org)
+
+%description
+This package adds the pear.horde.org channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/pear.horde.org.xml
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/pear.horde.org.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/pear.horde.org.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete pear.horde.org > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/pear.horde.org.xml
+
+%changelog
+* Mon Feb 20 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.0-1
+- backport for remi repo
+
+* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0-1
+- Initial package